Gentoo Archives: gentoo-announce

From: Tim Sammut <underling@g.o>
To: gentoo-announce@g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 201110-21 ] Asterisk: Multiple vulnerabilities
Date: Mon, 24 Oct 2011 19:03:12
Message-Id: 4EA5B50D.1070509@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201110-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Asterisk: Multiple vulnerabilities
     Date: October 24, 2011
     Bugs: #352059, #355967, #359767, #364887, #372793, #373409, #387453
       ID: 201110-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in Asterisk might allow unauthenticated remote
attackers to execute arbitrary code.

Background
==========

Asterisk is an open source telephony engine and toolkit.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-misc/asterisk           < 1.8.7.1                 >= 1.8.7.1
                                                       *>= 1.6.2.18.2

Description
===========

Multiple vulnerabilities have been discovered in Asterisk. Please
review the CVE identifiers referenced below for details.

Impact
======

An unauthenticated remote attacker may execute code with the privileges
of the Asterisk process or cause a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All asterisk 1.6.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.6.2.18.2"

All asterisk 1.8.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.7.1"

References
==========

[  1 ] CVE-2011-1147
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1147
[  2 ] CVE-2011-1174
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1174
[  3 ] CVE-2011-1175
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1175
[  4 ] CVE-2011-1507
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1507
[  5 ] CVE-2011-1599
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1599
[  6 ] CVE-2011-2529
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2529
[  7 ] CVE-2011-2535
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2535
[  8 ] CVE-2011-2536
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2536
[  9 ] CVE-2011-2665
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2665
[ 10 ] CVE-2011-2666
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2666
[ 11 ] CVE-2011-4063
       http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4063

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201110-21.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature