Gentoo Archives: gentoo-announce

From: Sean Amoss <ackle@g.o>
To: gentoo-announce@g.o
Subject: [gentoo-announce] [ GLSA 201203-22 ] nginx: Multiple vulnerabilities
Date: Wed, 28 Mar 2012 11:04:35
Message-Id: 4F72EEB3.9090909@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201203-22
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: nginx: Multiple vulnerabilities
     Date: March 28, 2012
     Bugs: #293785, #293786, #293788, #389319, #408367
       ID: 201203-22

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in nginx, the worst of which
may allow execution of arbitrary code.

Background
==========

nginx is a robust, small, and high performance HTTP and reverse proxy
server.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-servers/nginx            < 1.0.14                  >= 1.0.14

Description
===========

Multiple vulnerabilities have been found in nginx:

* The TLS protocol does not properly handle session renegotiation
  requests (CVE-2009-3555).
* The "ngx_http_process_request_headers()" function in ngx_http_parse.c
  could cause a NULL pointer dereference (CVE-2009-3896).
* nginx does not properly sanitize user input for the the WebDAV COPY
  or MOVE methods (CVE-2009-3898).
* The "ngx_resolver_copy()" function in ngx_resolver.c contains a
  boundary error which could cause a heap-based buffer overflow
  (CVE-2011-4315).
* nginx does not properly parse HTTP header responses which could
  expose sensitive information (CVE-2012-1180).

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the nginx process, cause a Denial of Service condition,
create or overwrite arbitrary files, or obtain sensitive information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All nginx users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-servers/nginx-1.0.14"

References
==========

[ 1 ] CVE-2009-3555
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3555
[ 2 ] CVE-2009-3896
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3896
[ 3 ] CVE-2009-3898
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3898
[ 4 ] CVE-2011-4315
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4315
[ 5 ] CVE-2012-1180
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1180

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201203-22.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature