Gentoo Archives: gentoo-announce

From: Alex Legler <a3li@g.o>
To: gentoo-announce@l.g.o
Cc: bugtraq@×××××××××××××.com, full-disclosure@××××××××××××××.uk, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 200907-01 ] libwmf: User-assisted execution of arbitrary code
Date: Thu, 02 Jul 2009 19:39:15
Message-Id: 1246563417.4324.0.camel@localhost
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200907-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: libwmf: User-assisted execution of arbitrary code
      Date: July 02, 2009
      Bugs: #268161
        ID: 200907-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

libwmf bundles an old GD version which contains a "use-after-free"
vulnerability.

Background
==========

libwmf is a library for converting WMF files.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /   Vulnerable   /                  Unaffected
    -------------------------------------------------------------------
  1  media-libs/libwmf     < 0.2.8.4-r3                  >= 0.2.8.4-r3

Description
===========

The embedded fork of the GD library introduced a "use-after-free"
vulnerability in a modification which is specific to libwmf.

Impact
======

A remote attacker could entice a user to open a specially crafted WMF
file, possibly resulting in the execution of arbitrary code with the
privileges of the user running the application, or a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libwmf users should upgrade to the latest version which no longer
builds the GD library:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-libs/libwmf-0.2.8.4-r3"

References
==========

  [ 1 ] CVE-2009-1364
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1364

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200907-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature