Gentoo Archives: gentoo-announce

From: Pierre-Yves Rofes <py@g.o>
To: gentoo-announce@l.g.o
Cc: full-disclosure@××××××××××××××.uk, bugtraq@×××××××××××××.com, security-alerts@×××××××××××××.com
Subject: [gentoo-announce] [ GLSA 200904-05 ] ntp: Certificate validation error
Date: Sun, 05 Apr 2009 13:58:55
Message-Id: 49D8B8A1.1070204@gentoo.org
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200904-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: ntp: Certificate validation error
      Date: April 05, 2009
      Bugs: #254098
        ID: 200904-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An error in the OpenSSL certificate chain validation in ntp might allow
for spoofing attacks.

Background
==========

ntp contains the client and daemon implementations for the Network Time
Protocol.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /  Vulnerable  /                         Unaffected
    -------------------------------------------------------------------
  1  net-misc/ntp     < 4.2.4_p6                           >= 4.2.4_p6

Description
===========

It has been reported that ntp incorrectly checks the return value of
the EVP_VerifyFinal(), a vulnerability related to CVE-2008-5077 (GLSA
200902-02).

Impact
======

A remote attacker could exploit this vulnerability to spoof arbitrary
names to conduct Man-In-The-Middle attacks and intercept sensitive
information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ntp users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-misc/ntp-4.2.4_p6"

References
==========

  [ 1 ] CVE-2008-5077
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5077
  [ 2 ] CVE-2009-0021
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0021
  [ 3 ] GLSA 200902-02
        http://www.gentoo.org/security/en/glsa/glsa-200902-02.xml

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200904-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachments

File name MIME type
signature.asc application/pgp-signature