Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Raphael Marichez <falco@g.o>
Subject: [ GLSA 200710-28 ] Qt: Buffer overflow
Date: Thu, 25 Oct 2007 23:46:24 +0200
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200710-28
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Qt: Buffer overflow
      Date: October 25, 2007
      Bugs: #192472
        ID: 200710-28

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An off-by-one vulnerability has been discovered in Qt, possibly
resulting in the execution of arbitrary code.

Background
==========

Qt is a cross-platform GUI framework, which is used e.g. by KDE.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /  Vulnerable  /                          Unaffected
    -------------------------------------------------------------------
  1  x11-libs/qt     < 3.3.8-r4                            >= 3.3.8-r4

Description
===========

Dirk Mueller from the KDE development team discovered a boundary error
in file qutfcodec.cpp when processing Unicode strings.

Impact
======

A remote attacker could send a specially crafted Unicode string to a
vulnerable Qt application, possibly resulting in the remote execution
of arbitrary code with the privileges of the user running the
application. Note that the boundary error is present but reported to be
not exploitable in 4.x series.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Qt 3.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-libs/qt-3.3.8-r4"

References
==========

  [ 1 ] CVE-2007-4137
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4137

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200710-28.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachment:
pgpGfFrTQiy26.pgp (PGP signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200710-27 ] ImageMagick: Multiple vulnerabilities
Next by thread:
[ GLSA 200710-29 ] Sylpheed, Claws Mail: User-assisted remote execution of arbitrary code
Previous by date:
[ GLSA 200710-27 ] ImageMagick: Multiple vulnerabilities
Next by date:
[ GLSA 200710-29 ] Sylpheed, Claws Mail: User-assisted remote execution of arbitrary code


Updated Jun 17, 2009

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.