Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Sean Amoss <ackle@g.o>
Subject: [ GLSA 201206-15 ] libpng: Multiple vulnerabilities
Date: Fri, 22 Jun 2012 07:06:26 -0400
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201206-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: libpng: Multiple vulnerabilities
     Date: June 22, 2012
     Bugs: #373967, #386185, #401987, #404197, #410153
       ID: 201206-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in libpng might allow remote attackers to
execute arbitrary code or cause a Denial of Service condition.

Background
==========

libpng is a standard library used to process PNG (Portable Network
Graphics) images. It is used by several programs, including web
browsers and potentially server processes.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  media-libs/libpng            < 1.5.10                  >= 1.5.10
                                                           *>= 1.2.49

Description
===========

Multiple vulnerabilities have been discovered in libpng:

* The "embedded_profile_len()" function in pngwutil.c does not check
  for negative values, resulting in a memory leak (CVE-2009-5063).
* The "png_format_buffer()" function in pngerror.c contains an
  off-by-one error (CVE-2011-2501).
* The "png_rgb_to_gray()" function in pngrtran.c contains an integer
  overflow error (CVE-2011-2690).
* The "png_err()" function in pngerror.c contains a NULL pointer
  dereference error (CVE-2011-2691).
* The "png_handle_sCAL()" function in pngrutil.c improperly handles
  malformed sCAL chunks(CVE-2011-2692).
* The "png_decompress_chunk()" function in pngrutil.c contains an
  integer overflow error (CVE-2011-3026).
* The "png_inflate()" function in pngrutil.c contains and out of bounds
  error (CVE-2011-3045).
* The "png_set_text_2()" function in pngset.c contains an error which
  could result in memory corruption (CVE-2011-3048).
* The "png_formatted_warning()" function in pngerror.c contains an
  off-by-one error (CVE-2011-3464).

Impact
======

An attacker could exploit these vulnerabilities to execute arbitrary
code with the permissions of the user running the vulnerable program,
which could be the root user, or to cause programs linked against the
library to crash.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libpng 1.5 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.5.10"

All libpng 1.2 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.49"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2009-5063
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-5063
[ 2 ] CVE-2011-2501
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2501
[ 3 ] CVE-2011-2690
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2690
[ 4 ] CVE-2011-2691
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2691
[ 5 ] CVE-2011-2692
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2692
[ 6 ] CVE-2011-3026
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3026
[ 7 ] CVE-2011-3045
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3045
[ 8 ] CVE-2011-3048
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3048
[ 9 ] CVE-2011-3464
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3464

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201206-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment:
signature.asc (OpenPGP digital signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 201206-14 ] Adobe Reader: Multiple vulnerabilities
Next by thread:
[ GLSA 201206-16 ] TagLib: Multiple vulnerabilities
Previous by date:
[ GLSA 201206-14 ] Adobe Reader: Multiple vulnerabilities
Next by date:
[ GLSA 201206-16 ] TagLib: Multiple vulnerabilities


Updated Jun 25, 2012

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.