Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Sune Kloppenborg Jeppesen <jaervosz@g.o>
Subject: [ GLSA 200508-09 ] bluez-utils: Bluetooth device name validation vulnerability
Date: Wed, 17 Aug 2005 18:11:22 +0200
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200508-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: bluez-utils: Bluetooth device name validation vulnerability
      Date: August 17, 2005
      Bugs: #101557
        ID: 200508-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Improper validation of Bluetooth device names can lead to arbitrary
command execution.

Background
==========

bluez-utils are the utilities for use with the BlueZ implementation of
the Bluetooth wireless standards for Linux.

Affected packages
=================

    -------------------------------------------------------------------
     Package                   /  Vulnerable  /             Unaffected
    -------------------------------------------------------------------
  1  net-wireless/bluez-utils       < 2.19                     >= 2.19

Description
===========

The name of a Bluetooth device is improperly validated by the hcid
utility when a remote device attempts to pair itself with a computer.

Impact
======

An attacker could create a malicious device name on a Bluetooth device
resulting in arbitrary commands being executed as root upon attempting
to pair the device with the computer.

Workaround
==========

There are no known workarounds at this time.

Resolution
==========

All bluez-utils users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-wireless/bluez-utils-2.19"

References
==========

  [ 1 ] CAN-2005-2547
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2547
  [ 2 ] bluez-utils ChangeLog
        http://cvs.sourceforge.net/viewcvs.py/bluez/utils/ChangeLog?rev=1.28&view=markup

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200508-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
Attachment:
pgplvXv2idAHj.pgp (PGP signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200508-08 ] Xpdf, Kpdf, GPdf: Denial of Service vulnerability
Next by thread:
[ GLSA 200508-10 ] Kismet: Multiple vulnerabilities
Previous by date:
[ GLSA 200508-08 ] Xpdf, Kpdf, GPdf: Denial of Service vulnerability
Next by date:
[ GLSA 200508-10 ] Kismet: Multiple vulnerabilities


Updated Jun 17, 2009

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.