Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Thierry Carrez <koon@g.o>
Subject: [ GLSA 200509-17 ] Webmin, Usermin: Remote code execution through PAM authentication
Date: Sat, 24 Sep 2005 12:49:18 +0200
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200509-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Webmin, Usermin: Remote code execution through PAM
            authentication
      Date: September 24, 2005
      Bugs: #106705
        ID: 200509-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

If Webmin or Usermin is configured to use full PAM conversations, it is
vulnerable to the remote execution of arbitrary code with root
privileges.

Background
==========

Webmin and Usermin are web-based system administration consoles. Webmin
allows an administrator to easily configure servers and other features.
Usermin allows users to configure their own accounts, execute commands,
and read e-mails.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  app-admin/webmin        < 1.230                          >= 1.230
  2  app-admin/usermin       < 1.160                          >= 1.160
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Keigo Yamazaki discovered that the miniserv.pl webserver, used in both
Webmin and Usermin, does not properly validate authentication
credentials before sending them to the PAM (Pluggable Authentication
Modules) authentication process. The default configuration shipped with
Gentoo does not enable the "full PAM conversations" option and is
therefore unaffected by this flaw.

Impact
======

A remote attacker could bypass the authentication process and run any
command as the root user on the target server.

Workaround
==========

Do not enable "full PAM conversations" in the Authentication options of
Webmin and Usermin.

Resolution
==========

All Webmin users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-admin/webmin-1.230"

All Usermin users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-admin/usermin-1.160"

References
==========

  [ 1 ] CAN-2005-3042
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-3042
  [ 2 ] Original Advisory

http://www.lac.co.jp/business/sns/intelligence/SNSadvisory_e/83_e.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200509-17.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

Attachment:
signature.asc (OpenPGP digital signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200509-16 ] Mantis: XSS and SQL injection vulnerabilities
Next by thread:
[ GLSA 200509-18 ] Qt: Buffer overflow in the included zlib library
Previous by date:
[ GLSA 200509-16 ] Mantis: XSS and SQL injection vulnerabilities
Next by date:
[ GLSA 200509-18 ] Qt: Buffer overflow in the included zlib library


Updated Jun 17, 2009

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.