Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Robert Buchholz <rbu@g.o>
Subject: [ GLSA 200907-11 ] GStreamer plug-ins: User-assisted execution of arbitrary code
Date: Sun, 12 Jul 2009 19:43:54 +0200
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200907-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: GStreamer plug-ins: User-assisted execution of arbitrary
            code
      Date: July 12, 2009
      Bugs: #256096, #261594, #272972
        ID: 200907-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in multiple GStreamer plug-ins might allow for
the execution of arbitrary code.

Background
==========

The GStreamer plug-ins provide decoders to the GStreamer open source
media framework.

Affected packages
=================

    -------------------------------------------------------------------
     Package                           /   Vulnerable   /   Unaffected
    -------------------------------------------------------------------
  1  media-libs/gst-plugins-good            < 0.10.14       >= 0.10.14
  2  media-libs/gst-plugins-base            < 0.10.22       >= 0.10.22
  3  media-plugins/gst-plugins-libpng     < 0.10.14-r1   >= 0.10.14-r1
    -------------------------------------------------------------------
     3 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Multiple vulnerabilities have been reported in several GStreamer
plug-ins:

* Tobias Klein reported two heap-based buffer overflows and an array
  index error in the qtdemux_parse_samples() function in
  gst-plugins-good when processing a QuickTime media .mov file
  (CVE-2009-0386, CVE-2009-0387, CVE-2009-0397).

* Thomas Hoger of the Red Hat Security Response Team reported an
  integer overflow that can lead to a heap-based buffer overflow in the
  gst_vorbis_tag_add_coverart() function in gst-plugins-base when
  processing COVERART tags (CVE-2009-0586).

* Tielei Wang of ICST-ERCIS, Peking University reported multiple
  integer overflows leading to buffer overflows in gst-plugins-libpng
  when processing a PNG file (CVE-2009-1932).

Impact
======

A remote attacker could entice a user or automated system using a
GStreamer plug-in to process a specially crafted file, resulting in the
execution of arbitrary code or a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All gst-plugins-good users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot -v ">=media-libs/gst-plugins-good-0.10.14"

All gst-plugins-base users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot -v ">=media-libs/gst-plugins-base-0.10.22"

All gst-plugins-libpng users should upgrade to the latest version:

    # emerge --sync
    # emerge -a -1 -v ">=media-plugins/gst-plugins-libpng-0.10.14-r1"

References
==========

  [ 1 ] CVE-2009-0386
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0386
  [ 2 ] CVE-2009-0387
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0387
  [ 3 ] CVE-2009-0397
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0397
  [ 4 ] CVE-2009-0586
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0586
  [ 5 ] CVE-2009-1932
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1932

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200907-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachment:
signature.asc (This is a digitally signed message part.)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200907-10 ] Syslog-ng: Chroot escape
Next by thread:
[ GLSA 200907-12 ] ISC DHCP: dhcpclient Remote execution of arbitrary code
Previous by date:
[ GLSA 200907-10 ] Syslog-ng: Chroot escape
Next by date:
[ GLSA 200907-12 ] ISC DHCP: dhcpclient Remote execution of arbitrary code


Updated Jun 25, 2012

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.