Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Sune Kloppenborg Jeppesen <jaervosz@g.o>
Subject: [ GLSA 200507-26 ] GNU Gadu, CenterICQ, Kadu, EKG, libgadu: Remote code execution in Gadu library
Date: Wed, 27 Jul 2005 08:58:40 +0200
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200507-26
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: GNU Gadu, CenterICQ, Kadu, EKG, libgadu: Remote code
            execution in Gadu library
      Date: July 27, 2005
      Bugs: #99816, #99890, #99583
        ID: 200507-26

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

GNU Gadu, CenterICQ, Kadu, EKG and libgadu are vulnerable to an integer
overflow which could potentially lead to the execution of arbitrary
code or a Denial of Service.

Background
==========

GNU Gadu, CenterICQ, Kadu and EKG are instant messaging applications
created to support Gadu Gadu instant messaging protocol. libgadu is a
library that implements the client side of the Gadu-Gadu protocol.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /   Vulnerable   /                   Unaffected
    -------------------------------------------------------------------
  1  net-im/gnugadu        < 2.2.6-r1                      >= 2.2.6-r1
  2  net-im/centericq      < 4.20.0-r3                    >= 4.20.0-r3
  3  net-im/kadu             < 0.4.1                          >= 0.4.1
  4  net-im/ekg             < 1.6_rc3                       >= 1.6_rc3
  5  net-libs/libgadu      < 20050719                      >= 20050719
    -------------------------------------------------------------------
     5 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

GNU Gadu, CenterICQ, Kadu, EKG and libgadu are vulnerable to an integer
overflow.

Impact
======

A remote attacker could exploit the integer overflow to execute
arbitrary code or cause a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GNU Gadu users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-im/gnugadu-2.2.6-r1"

All Kadu users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-im/kadu-0.4.1"

All EKG users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-im/ekg-1.6_rc3"

All libgadu users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-libs/libgadu-20050719"

All CenterICQ users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-im/centericq-4.20.0-r3"

CenterICQ is no longer distributed with Gadu Gadu support, affected
users are encouraged to migrate to an alternative package.

References
==========

  [ 1 ] CAN-2005-1852
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1852
  [ 2 ] BugTraq Announcement
        http://www.securityfocus.com/archive/1/406026/30/

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200507-26.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
Attachment:
pgpBRm5g0WHih.pgp (PGP signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200507-25 ] Clam AntiVirus: Integer overflows
Next by thread:
[ GLSA 200507-27 ] Ethereal: Multiple vulnerabilities
Previous by date:
[ GLSA 200507-25 ] Clam AntiVirus: Integer overflows
Next by date:
[ GLSA 200507-27 ] Ethereal: Multiple vulnerabilities


Updated Jun 17, 2009

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.