Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Pierre-Yves Rofes <py@g.o>
Subject: [ GLSA 200903-37 ] Ghostscript: User-assisted execution of arbitrary code
Date: Mon, 23 Mar 2009 23:34:00 +0100
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200903-37
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Ghostscript: User-assisted execution of arbitrary code
      Date: March 23, 2009
      Bugs: #261087
        ID: 200903-37

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple integer overflows in the Ghostscript ICC library might allow
for user-assisted execution of arbitrary code.

Background
==========

Ghostscript is an interpreter for the PostScript language and the
Portable Document Format (PDF).

Affected packages
=================

    -------------------------------------------------------------------
     Package                   /   Vulnerable   /           Unaffected
    -------------------------------------------------------------------
  1  app-text/ghostscript-gpl       < 8.64-r2               >= 8.64-r2
  2  app-text/ghostscript-gnu       < 8.62.0                 >= 8.62.0
  3  app-text/ghostscript-esp     <= 8.15.4-r1             Vulnerable!
    -------------------------------------------------------------------
     NOTE: Certain packages are still vulnerable. Users should migrate
           to another package if one is available or wait for the
           existing packages to be marked stable by their
           architecture maintainers.
    -------------------------------------------------------------------
     3 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Jan Lieskovsky from the Red Hat Security Response Team discovered the
following vulnerabilities in Ghostscript's ICC Library:

* Multiple integer overflows (CVE-2009-0583).

* Multiple insufficient bounds checks on certain variable sizes
  (CVE-2009-0584).

Impact
======

A remote attacker could entice a user to open a specially crafted
PostScript file containing images and a malicious ICC profile, possibly
resulting in the execution of arbitrary code with the privileges of the
user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GPL Ghostscript users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/ghostscript-gpl-8.64-r2"

All GNU Ghostscript users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/ghostscript-gnu-8.62.0"

We recommend that users unmerge ESP Ghostscript and use GPL or GNU
Ghostscript instead:

 # emerge --unmerge "app-text/ghostscript-esp"

For installation instructions, see above.

References
==========

  [ 1 ] CVE-2009-0583
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0583
  [ 2 ] CVE-2009-0584
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0584

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200903-37.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Attachment:
signature.asc (OpenPGP digital signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200903-36 ] MLDonkey: Information disclosure
Next by thread:
[ GLSA 200903-38 ] Squid: Multiple Denial of Service vulnerabilities
Previous by date:
[ GLSA 200903-36 ] MLDonkey: Information disclosure
Next by date:
[ GLSA 200903-38 ] Squid: Multiple Denial of Service vulnerabilities


Updated Jun 17, 2009

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.