Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Pierre-Yves Rofes <py@g.o>
Subject: [ GLSA 200903-41 ] gedit: Untrusted search path
Date: Mon, 30 Mar 2009 23:48:53 +0200
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200903-41
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: gedit: Untrusted search path
      Date: March 30, 2009
      Bugs: #257004
        ID: 200903-41

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in gedit might allow local attackers to execute
arbitrary code.

Background
==========

gedit is a text editor for the GNOME desktop.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  app-editors/gedit      < 2.24.3                     *>= 2.22.3-r1
                                                             >= 2.24.3

Description
===========

James Vega reported that gedit uses the current working directory when
searching for python modules, a vulnerability related to CVE-2008-5983.

Impact
======

A local attacker could entice a user to open gedit from a specially
crafted environment, possibly resulting in the execution of arbitrary
code with the privileges of the user running the application.

Workaround
==========

Do not run gedit from untrusted working directories.

Resolution
==========

All gedit 2.22.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-editors/gedit-2.22.3-r1"

All gedit 2.24.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-editors/gedit-2.24.3"

References
==========

  [ 1 ] CVE-2008-5983
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5983
  [ 2 ] CVE-2009-0314
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0314

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200903-41.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



Attachment:
signature.asc (OpenPGP digital signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200903-40 ] Analog: Denial of Service
Next by thread:
[ GLSA 200904-01 ] Openfire: Multiple vulnerabilities
Previous by date:
[ GLSA 200903-40 ] Analog: Denial of Service
Next by date:
[ GLSA 200904-01 ] Openfire: Multiple vulnerabilities


Updated Jun 17, 2009

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.