Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Sean Amoss <ackle@g.o>
Subject: [ GLSA 201203-06 ] sudo: Privilege escalation
Date: Mon, 05 Mar 2012 21:03:13 -0500
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201203-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: sudo: Privilege escalation
     Date: March 06, 2012
     Bugs: #351490, #401533
       ID: 201203-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two vulnerabilities have been discovered in sudo, allowing local
attackers to possibly gain escalated privileges.

Background
==========

sudo allows a system administrator to give users the ability to run
commands as other users.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  app-admin/sudo              < 1.8.3_p2               >= 1.8.3_p2
                                                         *>= 1.7.4_p5

Description
===========

Two vulnerabilities have been discovered in sudo:

* When the sudoers file is configured with a Runas group, sudo does not
  prompt for a password when changing to the new group (CVE-2011-0010).
* A format string vulnerability exists in the "sudo_debug()" function
  (CVE-2012-0809).

Impact
======

A local attacker could possibly gain the ability to run arbitrary
commands with the privileges of other users or groups, including root.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All sudo users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-admin/sudo-1.8.3_p2"

References
==========

[ 1 ] CVE-2011-0010
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-0010
[ 2 ] CVE-2012-0809
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0809

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201203-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment:
signature.asc (OpenPGP digital signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 201203-05 ] Rack: Denial of Service
Next by thread:
[ GLSA 201203-07 ] foomatic-filters: User-assisted execution of arbitrary code
Previous by date:
[ GLSA 201203-05 ] Rack: Denial of Service
Next by date:
[ GLSA 201203-07 ] foomatic-filters: User-assisted execution of arbitrary code


Updated Mar 06, 2012

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.