Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Robert Buchholz <rbu@g.o>
Subject: [ GLSA 200907-08 ] Multiple Ralink wireless drivers: Execution of arbitrary code
Date: Sun, 12 Jul 2009 19:41:17 +0200
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200907-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Multiple Ralink wireless drivers: Execution of arbitrary
            code
      Date: July 12, 2009
      Bugs: #257023
        ID: 200907-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An integer overflow in multiple Ralink wireless drivers might lead to
the execution of arbitrary code with elevated privileges.

Background
==========

All listed packages are external kernel modules that provide drivers
for multiple Ralink devices. ralink-rt61 is released by ralinktech.com,
the other packages by the rt2x00.serialmonkey.com project.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /        Vulnerable        /              Unaffected
    -------------------------------------------------------------------
  1  rt2400              <= 1.2.2_beta3                    Vulnerable!
  2  rt2500          <= 1.1.0_pre2007071515                Vulnerable!
  3  rt2570                <= 20070209                     Vulnerable!
  4  rt61                <= 1.1.0_beta2                    Vulnerable!
  5  ralink-rt61           <= 1.1.1.0                      Vulnerable!
    -------------------------------------------------------------------
     NOTE: Certain packages are still vulnerable. Users should migrate
           to another package if one is available or wait for the
           existing packages to be marked stable by their
           architecture maintainers.
    -------------------------------------------------------------------
     5 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Aviv reported an integer overflow in multiple Ralink wireless card
drivers when processing a probe request packet with a long SSID,
possibly related to an integer signedness error.

Impact
======

A physically proximate attacker could send specially crafted packets to
a user who has wireless networking enabled, possibly resulting in the
execution of arbitrary code with root privileges.

Workaround
==========

Unload the kernel modules.

Resolution
==========

All external kernel modules have been masked and we recommend that
users unmerge those drivers. The Linux mainline kernel has equivalent
support for these devices and the vulnerability has been resolved in
stable versions of sys-kernel/gentoo-sources.

    # emerge --unmerge "net-wireless/rt2400"
    # emerge --unmerge "net-wireless/rt2500"
    # emerge --unmerge "net-wireless/rt2570"
    # emerge --unmerge "net-wireless/rt61"
    # emerge --unmerge "net-wireless/ralink-rt61"

References
==========

  [ 1 ] CVE-2009-0282
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0282

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200907-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachment:
signature.asc (This is a digitally signed message part.)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200907-07 ] ModPlug: User-assisted execution of arbitrary code
Next by thread:
[ GLSA 200907-09 ] Cyrus-SASL: Execution of arbitrary code
Previous by date:
[ GLSA 200907-07 ] ModPlug: User-assisted execution of arbitrary code
Next by date:
[ GLSA 200907-09 ] Cyrus-SASL: Execution of arbitrary code


Updated Jun 25, 2012

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.