Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Alex Legler <a3li@g.o>
Subject: [ GLSA 201201-16 ] X.Org X Server/X Keyboard Configuration Database: Screen lock bypass
Date: Fri, 27 Jan 2012 22:59:40 +0100
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201201-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: X.Org X Server/X Keyboard Configuration Database: Screen lock
           bypass
     Date: January 27, 2012
     Bugs: #399347
       ID: 201201-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A debugging functionality in the X.Org X Server that is bound to a
hotkey by default can be used by local attackers to circumvent screen
locking utilities.

Background
==========

The X Keyboard Configuration Database provides keyboard configuration
for various X server implementations.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  x11-misc/xkeyboard-config
                                 < 2.4.1-r3               >= 2.4.1-r3 
    -------------------------------------------------------------------
     # Package 1 only applies to users of these architectures:
       amd64, arm, hppa, x86

Description
===========

Starting with the =x11-base/xorg-server-1.11 package, the X.Org X
Server again provides debugging functionality that can be used
terminate an application that exclusively grabs mouse and keyboard
input, like screen locking utilities.

Gu1 reported that the X Keyboard Configuration Database maps this
functionality by default to the Ctrl+Alt+Numpad * key combination.

Impact
======

A physically proximate attacker could exploit this vulnerability to
gain access to a locked X session without providing the correct
credentials.

Workaround
==========

Downgrade to any version of x11-base/xorg-server below
x11-base/xorg-server-1.11:

  # emerge --oneshot --verbose "<x11-base/xorg-server-1.11"

Resolution
==========

All xkeyboard-config users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=x11-misc/xkeyboard-config-2.4.1-r3"

NOTE: The X.Org X Server 1.11 was only stable on the AMD64, ARM, HPPA,
and x86 architectures. Users of the stable branches of all other
architectures are not affected and will be directly provided with a
fixed X Keyboard Configuration Database version.

References
==========

[ 1 ] CVE-2012-0064
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0064

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201201-16.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachment:
signature.asc (This is a digitally signed message part.)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 201201-15 ] ktsuss: Privilege escalation
Next by thread:
[ GLSA 201201-17 ] Chromium: Multiple vulnerabilities
Previous by date:
[ GLSA 201201-15 ] ktsuss: Privilege escalation
Next by date:
[ GLSA 201201-17 ] Chromium: Multiple vulnerabilities


Updated Jun 25, 2012

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.