Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-announce
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-announce@g.o
From: Alex Legler <a3li@g.o>
Subject: [ GLSA 200909-06 ] aMule: Parameter injection
Date: Wed, 9 Sep 2009 15:21:42 +0200
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200909-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: aMule: Parameter injection
      Date: September 09, 2009
      Bugs: #268163
        ID: 200909-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An input validation error in aMule enables remote attackers to pass
arbitrary parameters to a victim's media player.

Background
==========

aMule is an eMule-like client for the eD2k and Kademlia networks,
supporting multiple platforms.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /  Vulnerable  /                        Unaffected
    -------------------------------------------------------------------
  1  net-p2p/amule       < 2.2.5                              >= 2.2.5

Description
===========

Sam Hocevar discovered that the aMule preview function does not
properly sanitize file names.

Impact
======

A remote attacker could entice a user to download a file with a
specially crafted file name to inject arbitrary arguments to the
victim's video player.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All aMule users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose =net-p2p/amule-2.2.5

References
==========

  [ 1 ] CVE-2009-1440
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1440

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200909-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@g.o or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
Attachment:
signature.asc (PGP signature)
Navigation:
Lists: gentoo-announce: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
[ GLSA 200909-05 ] Openswan: Denial of Service
Next by thread:
[ GLSA 200909-07 ] TkMan: Insecure temporary file usage
Previous by date:
[ GLSA 200909-05 ] Openswan: Denial of Service
Next by date:
[ GLSA 200909-07 ] TkMan: Insecure temporary file usage


Updated Jun 25, 2012

Summary: Archive of the gentoo-announce mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.