Gentoo Archives: gentoo-commits

From: "Robert Buchholz (rbu)" <rbu@g.o>
To: gentoo-commits@l.g.o
Subject: [gentoo-commits] gentoo-x86 commit in net-im/openfire: ChangeLog openfire-3.6.3.ebuild openfire-3.6.0a.ebuild openfire-3.5.2.ebuild openfire-3.6.0.ebuild
Date: Tue, 13 Jan 2009 12:42:25
Message-Id: E1LMib7-0001vV-EG@stork.gentoo.org
rbu         09/01/13 12:42:21

  Modified:             ChangeLog
  Added:                openfire-3.6.3.ebuild
  Removed:              openfire-3.6.0a.ebuild openfire-3.5.2.ebuild
                        openfire-3.6.0.ebuild
  Log:
  +*openfire-3.6.3 (13 Jan 2009)
  +
  +  13 Jan 2009; Robert Buchholz <rbu@g.o> -openfire-3.5.2.ebuild,
  +  -openfire-3.6.0.ebuild, -openfire-3.6.0a.ebuild, +openfire-3.6.3.ebuild:
  +  Proxy commit for jokey: Version bump (bug #248857) for security bug (#254309)
  +  fixing a Cross-Site Scripting vulnerability that can be exploited to execute
  +  arbitrary code on the server.
  (Portage version: 2.1.6.5/cvs/Linux 2.6.28 x86_64)

Revision  Changes    Path
1.31                 net-im/openfire/ChangeLog

file : http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-im/openfire/ChangeLog?rev=1.31&view=markup
plain: http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-im/openfire/ChangeLog?rev=1.31&content-type=text/plain
diff : http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-im/openfire/ChangeLog?r1=1.30&r2=1.31

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v
retrieving revision 1.30
retrieving revision 1.31
diff -u -r1.30 -r1.31
--- ChangeLog	16 Nov 2008 18:00:03 -0000	1.30
+++ ChangeLog	13 Jan 2009 12:42:21 -0000	1.31
@@ -1,6 +1,14 @@
 # ChangeLog for net-im/openfire
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v 1.30 2008/11/16 18:00:03 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/ChangeLog,v 1.31 2009/01/13 12:42:21 rbu Exp $
+
+*openfire-3.6.3 (13 Jan 2009)
+
+  13 Jan 2009; Robert Buchholz <rbu@g.o> -openfire-3.5.2.ebuild,
+  -openfire-3.6.0.ebuild, -openfire-3.6.0a.ebuild, +openfire-3.6.3.ebuild:
+  Proxy commit for jokey: Version bump (bug #248857) for security bug (#254309)
+  fixing a Cross-Site Scripting vulnerability that can be exploited to execute
+  arbitrary code on the server.
 
   16 Nov 2008; Markus Meier <maekke@g.o> openfire-3.6.1.ebuild:
   amd64/x86 stable, bug #246008



1.1                  net-im/openfire/openfire-3.6.3.ebuild

file : http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-im/openfire/openfire-3.6.3.ebuild?rev=1.1&view=markup
plain: http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-im/openfire/openfire-3.6.3.ebuild?rev=1.1&content-type=text/plain

Index: openfire-3.6.3.ebuild
===================================================================
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/openfire/openfire-3.6.3.ebuild,v 1.1 2009/01/13 12:42:21 rbu Exp $

inherit eutils java-pkg-2 java-ant-2

MY_P=${PN}_src_${PV//./_}
DESCRIPTION="Openfire (formerly wildfire) real time collaboration (RTC) server"
HOMEPAGE="http://www.igniterealtime.org/projects/openfire/"
SRC_URI="http://www.igniterealtime.org/builds/openfire/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

RDEPEND=">=virtual/jre-1.5"
DEPEND="net-im/jabber-base
		~dev-java/ant-contrib-1.0_beta2
		>=virtual/jdk-1.5"

S=${WORKDIR}/${PN}_src

RESTRICT=""

# For transports
PROVIDE="virtual/jabber-server"

pkg_setup() {
	if [ -f /etc/env.d/98openfire ]; then
		einfo "This is an upgrade"
		ewarn "As the plugin API changed, at least these plugins need to be updated also:"
		ewarn "User Search, IM Gateway, Fastpath, Monitoring"
		ewarn "hey can be downloaded via Admin Console or at"
		ewarn "${HOMEPAGE}"
	else
		ewarn "If this is an upgrade stop right ( CONTROL-C ) and run the command:"
		ewarn "echo 'CONFIG_PROTECT=\"/opt/openfire/resources/security/\"' > /etc/env.d/98openfire "
		ewarn "For more info see bug #139708"
		sleep 11
	fi
	java-pkg-2_pkg_setup
}

src_unpack() {
	unpack ${A}
	cd "${S}"
	epatch "${FILESDIR}"/buildxml.patch

	# TODO should replace jars in build/lib with ones packaged by us -nichoj
}

src_compile() {
	# Jikes doesn't support -source 1.5
	java-pkg_filter-compiler jikes

	ANT_TASKS="ant-contrib"
	eant -f build/build.xml openfire plugins $(use_doc)
}

src_install() {
	dodir /opt/openfire

	newinitd "${FILESDIR}"/openfire-initd openfire
	newconfd "${FILESDIR}"/openfire-confd openfire

	dodir /opt/openfire/conf
	insinto /opt/openfire/conf
	newins target/openfire/conf/openfire.xml openfire.xml.sample

	dodir /opt/openfire/logs
	keepdir /opt/openfire/logs

	dodir /opt/openfire/lib
	insinto /opt/openfire/lib
	doins target/openfire/lib/*

	dodir /opt/openfire/plugins
	insinto /opt/openfire/plugins
	doins -r target/openfire/plugins/*

	dodir /opt/openfire/resources
	insinto /opt/openfire/resources
	doins -r target/openfire/resources/*

	if use doc; then
		dohtml -r documentation/docs/*
	fi
	dodoc documentation/dist/*

	#Protect ssl key on upgrade
	dodir /etc/env.d/
	echo 'CONFIG_PROTECT="/opt/openfire/resources/security/"' > "${D}"/etc/env.d/98openfire
}

pkg_postinst() {
	chown -R jabber:jabber /opt/openfire

	ewarn If this is a new install, please edit /opt/openfire/conf/openfire.xml.sample
	ewarn and save it as /opt/openfire/conf/openfire.xml
	ewarn
	ewarn The following must be be owned or writable by the jabber user.
	ewarn /opt/openfire/conf/openfire.xml
	ewarn
	ewarn If you are upgrading please have a look at the Wildfire to Openfire Upgrade Guide:
	ewarn http://wiki.igniterealtime.org/display/WILDFIRE/Wildfire+to+Openfire+Upgrade+Guide
	ewarn
	ewarn Also there is a known issue about IQ Packets and connection drops
	ewarn see http://www.igniterealtime.org/issues/browse/JM-1465 for details
}