Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-cygwin
Navigation:
Lists: gentoo-cygwin: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-cygwin@g.o
From: "Michael Sullivan" <michael@...>
Subject: Re: Can't emerge ncurses
Date: Tue, 8 Jan 2008 13:04:47 -0600 (CST)
On Mon, January 7, 2008 4:53 am, Stephane Mikaty wrote:
> How did you setup your environment? That is, what are all the steps you
> went
> through to get to this error message? Include the setup instructions for
> portage, and all the wget commands for the source packages, and every
> command
> you typed in your shell up to the point of failure. This would allow
> people
> to reproduce the problem first. Without this, it's extremely difficult to
> help.
>
> Cheers
>
> Stephane
>
> On Sunday 06 January 2008 18:13:05 Michael Sullivan wrote:
>> I'm still trying to get my cywin-with-gentoo system working.  I can't
>> successfully build ncurses-5.6-r2.  The complete build listing is at
>> http://www.espersunited.com/~michael/ncurses.txt , but the end of it is
>>
>> ranlib ../lib/libncurses.a
>> Can't open .lib file: ../lib/libncurses.dll.a
>> collect2: ld returned 1 exit status
>> make[1]: *** [../lib/cygncurses5.dll] Error 1
>> make[1]: *** Waiting for unfinished jobs....
>> Creating library file: ../lib/libncurses.dll.a
>> make[1]: Leaving directory
>> `/var/tmp/portage/ncurses-5.6-r2/work/narrowc/ncurses' make: *** [all]
>> Error 2
>>
>> !!! ERROR: sys-libs/ncurses-5.6-r2 failed.
>> !!! Function do_compile, Line 103, Exitcode 2
>> !!! make failed
>> !!! If you need support, post the topmost build error, NOT this status
>> message.
>>
>> I know this list is mostly dead, but is there anyone still on it that
>> can
>> help me?
>
>
>

OK.  I've followed the wiki article without problems except for the rebase
bit.  I issued the rebase command in /usr/lib/python2.5/lib-dynload;
several DLLs appeared in the ls listing, but when I tried to run the
rebase command, it listed each one and said that it was skipping them
because they were nonexistent.  Is this a problem?  I've run the emerge
--sync and am attempting to emerge system, but it said that it couldn't
find an ebuild to satisfy sys-apps/sed-4.1.4, so I'm trying for sed-4.1.5
which I do have an ebuild for.  I've (theoretically) cleared all packages
in /etc/portage/package.keywords.  Now I see that my sed emerge has failed
because "there are no ebuilds to satisfy "cygwin-binaries/libgettextpo0" 
How do I work around this?

-- 
gentoo-cygwin@g.o mailing list


Replies:
Re: Can't emerge ncurses
-- Jason Alonso
References:
Can't emerge ncurses
-- Michael Sullivan
Re: Can't emerge ncurses
-- Stephane Mikaty
Navigation:
Lists: gentoo-cygwin: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Can't emerge ncurses
Next by thread:
Re: Can't emerge ncurses
Previous by date:
Re: Can't emerge ncurses
Next by date:
Re: Can't emerge ncurses


Updated Jun 17, 2009

Summary: Archive of the gentoo-cygwin mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.