Gentoo Archives: gentoo-desktop

From: Lindsay Haisley <fmouse-gentoo@×××.com>
To: gentoo-desktop@l.g.o
Subject: Re: [gentoo-desktop] System problems
Date: Wed, 23 Mar 2011 17:31:07
Message-Id: 1300901370.21521.65.camel@vishnu.fmp.com
In Reply to: Re: [gentoo-desktop] System problems by James Cloos
On Wed, 2011-03-23 at 08:39 -0400, James Cloos wrote:
> With current udev, I use devtmpfs for /dev. It looks like having > devtmpfs support compiled into the kernel is enough. > > If you don't have that, or if there is something in /etc/fstab > competing > against /etc/init.d/udev-mount, that might explain the problem.
Thanks. Jorge Vicetto noted that having CONFIG_SYSFS_DEPRECATED_V2 set in the kernel config is a major no-no with recent versions of udev, and will screw up device creation. This kernel config setting was indeed set, which may well have accounted for this particular incarnation of the problem. Roman Zilka noted that the 2.6.29 kernel I was using when this happens has known issues and isn't even in the Gentoo portage tree anymore. So thanks to Roman and Jorge I have a 2.6.36 kernel built (without the problem setting) which I'll try when I get a moment. Being a day late and a dollar short at the moment I'm a bit short on round tuits :-) -- Lindsay Haisley | "The difference between a duck is because FMP Computer Services | one leg is both the same" 512-259-1190 | - Anonymous http://www.fmp.com |

Replies

Subject Author
Re: [gentoo-desktop] System problems Dale <rdalek1967@×××××.com>