Gentoo Archives: gentoo-desktop

From: Roman <lists@×××××××××.de>
To: gentoo-desktop@l.g.o
Subject: Re: [gentoo-desktop] kde-sunset: kdepim-kresources broken
Date: Thu, 18 Feb 2010 10:03:09
Message-Id: 201002181101.50970.lists@hasnoname.de
In Reply to: Re: [gentoo-desktop] kde-sunset: kdepim-kresources broken by Ladislav Laska
Hi,

yes you are correct, adding
src_unpack() {
     kde-meta_src_unpack
     epatch "${WORKDIR}/patches/kdepim-kresources-3.5_use-installed-kode.diff"
}

to the ebuild works, but since PATCHES is used by some more ebuilds i guess 
there should be a better solution integrating to eclass...

Am Thursday 18 February 2010 02:44:26 schrieb Ladislav Laska:
> You're right. I've looked into this earlier today and it is problem > fixed by that patch, which is correctly added to PATCHES environment > variable and should be applied by base eclass, but it's not (and I > don't know why) - I'll try to figure it out tomorrow. > > Regards Ladislav Laska > S pozdravem Ladislav Laska > --- > xmpp/jabber: ladislav.laska@××××××.cz > > On Thu, Feb 18, 2010 at 1:39 AM, Chris Bandy <cbandy@××××××.com> wrote: > > Chris Bandy wrote: > >> Chris Bandy wrote: > >>> Roman wrote: > >>>> Am Thursday 11 February 2010 10:56:29 schrieb Roman: > >>>>> hi, > >>>>> > >>>>> just tried a clean reinstall of kde3.5, but it looks like sth. > >>>>> changed again and kdepim-kresources won't install anymore. > >>>>> Since i am already leaving for the weekend, maybe so else could have > >>>>> a look at it? If not i will look into it next week... > >>>> > >>>> Ok,  to f'up on myself... i tried looking into it, but looks like i > >>>> have not really an idea on how to fix it, it might be related to the > >>>> lates autotools update... > >>>> > >>>> greetings, > >>>> Roman > >>> > >>> I ran into this as well while moving from media-libs/jpeg-7 to 8.  I > >>> attach my info and build log after clearing ccache.  Can anyone shed > >>> some light? > >>> > >>> I haven't tried this[1] since the breakage does not look the same, but > >>> I may try it soon. > >>> > >>> [1] http://forums.gentoo.org/viewtopic-t-791293.html > >>> > >>> -- Chris > >> > >> Yikes.  I'm glad my mail wasn't rejected!  If you'd like to keep your > >> inbox small, I've made pastes of my info[1] and build.log[2]. > >> > >> [1] http://bandy.pastebin.com/m78ae7eda > >> [2] http://bandy.pastebin.com/m560638ac  (359 kB) > >> > >> -- Chris > > > > It looks like this patch ( kdepim-kresources-3.5_use-installed-kode.diff > > ) is not getting applied, but this is as far as I can dig today. > > > > -- Chris
Mit freundlichem Gruß, Roman v. Gemmeren -- The problem with any unwritten law is that you don't know where to go to erase it. -- Glaser and Way

Replies

Subject Author
Re: [gentoo-desktop] kde-sunset: kdepim-kresources broken Ladislav Laska <ladislav.laska@×××××.com>