Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-desktop
Navigation:
Lists: gentoo-desktop: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-desktop@g.o
From: Chris Bandy <cbandy@...>
Subject: Re: kde-sunset: kdepim-kresources broken
Date: Thu, 18 Feb 2010 23:13:48 -0600
Ladislav Laska wrote:
> Some more info:
>
> PATCHES are handled in base.eclass, in src_prepare. So EAPI has to be
> at least 2 for this to be handled. However, I don't know why
> base_src_prepare is not called and where to call it (well, I know that
> it *could* be called at the end of kde_src_unpack, but I'm not sure if
> it's correct and could break other packages).
>
> Regards Ladislav Laska
> S pozdravem Ladislav Laska
> ---
> xmpp/jabber: ladislav.laska@...
>
>
>
> On Thu, Feb 18, 2010 at 11:01 AM, Roman <lists@...> wrote:
>   
>> Hi,
>>
>> yes you are correct, adding
>> src_unpack() {
>>     kde-meta_src_unpack
>>     epatch "${WORKDIR}/patches/kdepim-kresources-3.5_use-installed-kode.diff"
>> }
>>
>> to the ebuild works, but since PATCHES is used by some more ebuilds i guess
>> there should be a better solution integrating to eclass...
>>
>> Am Thursday 18 February 2010 02:44:26 schrieb Ladislav Laska:
>>     
>>> You're right. I've looked into this earlier today and it is problem
>>> fixed by that patch, which is correctly added to PATCHES environment
>>> variable and should be applied by base eclass, but it's not (and I
>>> don't know why) - I'll try to figure it out tomorrow.
>>>
>>> Regards Ladislav Laska
>>> S pozdravem Ladislav Laska
>>> ---
>>> xmpp/jabber: ladislav.laska@...
>>>
>>> On Thu, Feb 18, 2010 at 1:39 AM, Chris Bandy <cbandy@...> wrote:
>>>       
>>>> Chris Bandy wrote:
>>>>         
>>>>> Chris Bandy wrote:
>>>>>           
>>>>>> Roman wrote:
>>>>>>             
>>>>>>> Am Thursday 11 February 2010 10:56:29 schrieb Roman:
>>>>>>>               
>>>>>>>> hi,
>>>>>>>>
>>>>>>>> just tried a clean reinstall of kde3.5, but it looks like sth.
>>>>>>>> changed again and kdepim-kresources won't install anymore.
>>>>>>>> Since i am already leaving for the weekend, maybe so else could have
>>>>>>>> a look at it? If not i will look into it next week...
>>>>>>>>                 
>>>>>>> Ok,  to f'up on myself... i tried looking into it, but looks like i
>>>>>>> have not really an idea on how to fix it, it might be related to the
>>>>>>> lates autotools update...
>>>>>>>
>>>>>>> greetings,
>>>>>>> Roman
>>>>>>>               
>>>>>> I ran into this as well while moving from media-libs/jpeg-7 to 8.  I
>>>>>> attach my info and build log after clearing ccache.  Can anyone shed
>>>>>> some light?
>>>>>>
>>>>>> I haven't tried this[1] since the breakage does not look the same, but
>>>>>> I may try it soon.
>>>>>>
>>>>>> [1] http://forums.gentoo.org/viewtopic-t-791293.html
>>>>>>
>>>>>> -- Chris
>>>>>>             
>>>>> Yikes.  I'm glad my mail wasn't rejected!  If you'd like to keep your
>>>>> inbox small, I've made pastes of my info[1] and build.log[2].
>>>>>
>>>>> [1] http://bandy.pastebin.com/m78ae7eda
>>>>> [2] http://bandy.pastebin.com/m560638ac  (359 kB)
>>>>>
>>>>> -- Chris
>>>>>           
>>>> It looks like this patch ( kdepim-kresources-3.5_use-installed-kode.diff
>>>> ) is not getting applied, but this is as far as I can dig today.
>>>>
>>>> -- Chris
>>>>         
>> Mit freundlichem Gruß,
>> Roman v. Gemmeren
>>
>> --
>> The problem with any unwritten law is that you don't know where to go
>> to erase it.
>>                -- Glaser and Way
>>     

base_src_prepare is not called because the directory already exists at
line 149 of kde.eclass. I strongly suspect commit
9704c7d47bbf70ec8f3fd78fd3b00e7603dfa879 broke it.

I have attached my build.log of "emerge --debug -1
kde-base/kdepim-kresources:3.5" The portion of interest starts around
line 10574.

I have also noticed that PATCHES were not applied for
kde-base/kicker-3.5.10-r2, in case that helps.  Though I suspect no
PATCHES are being applied when EAPI="1".

-- Chris
Attachment:
build.log.lzma (Binary data)
Replies:
Re: kde-sunset: kdepim-kresources broken
-- Chris Bandy
References:
kde-sunset: kdepim-kresources broken
-- Roman
Re: kde-sunset: kdepim-kresources broken
-- Chris Bandy
Re: kde-sunset: kdepim-kresources broken
-- Ladislav Laska
Re: kde-sunset: kdepim-kresources broken
-- Roman
Re: kde-sunset: kdepim-kresources broken
-- Ladislav Laska
Navigation:
Lists: gentoo-desktop: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: kde-sunset: kdepim-kresources broken
Next by thread:
Re: kde-sunset: kdepim-kresources broken
Previous by date:
Gentoo KDE meeting
Next by date:
Re: kde-sunset: kdepim-kresources broken


Updated Jun 28, 2012

Summary: Archive of the gentoo-desktop mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.