Gentoo Archives: gentoo-dev-announce

From: Jeremy Olexa <darkside@g.o>
To: gentoo-dev-announce@l.g.o
Subject: [gentoo-dev-announce] Removing USE={python,perl} from profile defaults (bug 250179)
Date: Fri, 23 Sep 2011 14:58:02
Message-Id: CAMxqorWSnii33Y27mstyK5-ysRVcYT-3QHCLkJyFz7Y_ykMHkg@mail.gmail.com
Hi all -

Just wanted to send a heads up that I'll be removing USE=python and
USE=perl from the profiles such that they will NOT be enabled by
default. There are justifications in the bug report if you care to
read. There have been appropriate tests done and stage building will
work fine. I'll write a little blog post that will goto
planet.gentoo.org so that users have some idea of why portage may warn
about needed package.use settings, etc. There is little
impact/inconvenience on users since the tree has appropriate USE deps
for most packages, packages without use deps are not well used (imo)
and will get flushed out with this change.

I'll be doing this early next week, so let's say in 3-5 days. I check
gentoo-dev archives but don't subscribe, instead you should file
blockers against bug 250179 if there is something that you feel is an
issue at hand.

Thanks,
Jeremy