Gentoo Archives: gentoo-dev

From: Gilles Dartiguelongue <eva@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Over using preserve_old_lib, don't do that
Date: Thu, 15 Jul 2010 09:09:55
Message-Id: 1279184979.22198.1.camel@gdartigu.lan.rep.sj
In Reply to: Re: [gentoo-dev] Over using preserve_old_lib, don't do that by Mike Auty
Le jeudi 15 juillet 2010 à 09:49 +0100, Mike Auty a écrit :
[...]
> I can live with this for in places where it causes massive breakage > (openssl/libpng/libjpg), because it's genuinely useful, but I think it > should be restricted to such important packages, or at least disabled by > FEATURES="-preserve-libs". > > Ideally, these calls should either adhere to FEATURES="-preserve-libs", > or there should be a tool that can identify which files portage has > preserved, and allow easy rebuilding of dependent packages, and removal. > At the moment, I'm having to manually grep ebuilds, ls the libraries > and run revdep-rebuild over them one at a time...
These sound like very good ideas to me. -- Gilles Dartiguelongue <eva@g.o> Gentoo

Replies

Subject Author
[gentoo-dev] Re: Over using preserve_old_lib, don't do that Duncan <1i5t5.duncan@×××.net>