Gentoo Archives: gentoo-dev

From: "Michał Górny" <mgorny@g.o>
To: gentoo-dev@l.g.o
Cc: flameeyes@g.o
Subject: Re: [gentoo-dev] Re: [PATCH autotools-utils] Deprecate implicit IUSE=debug.
Date: Wed, 14 Sep 2011 16:17:30
Message-Id: 20110914181603.2573b4d7@pomiocik.lan
In Reply to: [gentoo-dev] Re: [PATCH autotools-utils] Deprecate implicit IUSE=debug. by "Diego Elio Pettenò"
On Wed, 14 Sep 2011 17:56:05 +0200
Diego Elio Pettenò <flameeyes@g.o> wrote:

> Il giorno mer, 14/09/2011 alle 17.23 +0200, Michał Górny ha scritto: > > > > + eqawarn 'Implicit $(use_enable debug) for > > IUSE="debug" is deprecated.' > > + eqawarn 'Please add the necessary arg to > > myeconfargs if requested.' > > + eqawarn 'The autotools-utils eclass will > > stop appending it on Oct 15th.' > > Ehm, no. Just change all of it together and be done with it. If it > wasn't misused this would at worse cause some overlay to not build > debug properly; if it was misused then it would solve more issues > than it would cause.
Er; but then overlay authors won't even get a warning that the API changed. -- Best regards, Michał Górny

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-dev] Re: [PATCH autotools-utils] Deprecate implicit IUSE=debug. "Diego Elio Pettenò" <flameeyes@g.o>