Gentoo Archives: gentoo-dev

From: Mike Frysinger <vapier@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Pending removal(?) of media-libs/pdflib
Date: Tue, 22 Feb 2011 08:00:58
Message-Id: 201102220300.10071.vapier@gentoo.org
In Reply to: Re: [gentoo-dev] Pending removal(?) of media-libs/pdflib by Ulrich Mueller
On Tuesday, February 22, 2011 02:29:06 Ulrich Mueller wrote:
> >>>>> On Mon, 21 Feb 2011, Jeremy Olexa wrote: > > The bugs are stacking up[1] and upstream only offers a paid version of > > pdflib-8[2]. It is my understanding that there is no way for us to > > package future versions and the bundled libs are vulnerable[3]. > > > > So, should it be removed? For more info, see the tracker bug for its > > removal[1], there are a number of rdeps that will require fixing[4]. > > sci-visualization/gnuplot[pdf] is currently linking against pdflib. > I'm going to remove that dependency, because in my understanding, > clause 2.1 of the PDFLite license does not allow such linking. > (It allows it for programs under an OSI approved license. However, the > gnuplot license is free, but not OSI approved.)
that might disallow it for binaries, but it doesnt disallow it from being used in ebuilds. same situation as binary kernel drivers -- make it the end user's problem. -mike

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-dev] Pending removal(?) of media-libs/pdflib Ulrich Mueller <ulm@g.o>