Gentoo Archives: gentoo-dev

From: Samuli Suominen <ssuominen@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] forcing recent patch-2.6.1 everywhere
Date: Thu, 17 May 2012 20:17:21
Message-Id: 4FB55C7E.205@gentoo.org
In Reply to: Re: [gentoo-dev] forcing recent patch-2.6.1 everywhere by "Aaron W. Swenson"
On 05/17/2012 11:00 PM, Aaron W. Swenson wrote:
> -----BEGIN PGP SIGNED MESSAGE----- > Hash: SHA256 > > On 05/17/2012 03:51 PM, Mike Frysinger wrote: >> any complaints ? -mike >> >> Index: profiles/base/packages >> =================================================================== >> >> > RCS file: /var/cvsroot/gentoo-x86/profiles/base/packages,v >> retrieving revision 1.62 diff -u -p -r1.62 packages --- >> profiles/base/packages 12 Mar 2012 09:13:37 -0000 1.62 +++ >> profiles/base/packages 17 May 2012 19:50:49 -0000 @@ -61,7 +61,7 >> @@ #*sys-devel/libtool #*sys-devel/m4 *sys-devel/make >> -*sys-devel/patch +*>=sys-devel/patch-2.6.1 *sys-fs/e2fsprogs >> *virtual/dev-manager *virtual/editor > > What's the advantage/reward?
<patch-2.6.1 fails if patch contains DOS -line endings, like the ones you get from some crappy pastebin services or Trac's webservice >=patch-2.6.1 doesn't have this problem, and this is what developers are using anyway so less breakage, no possibility of these things slipping by consistent behavior profit! - Samuli

Replies

Subject Author
Re: [gentoo-dev] forcing recent patch-2.6.1 everywhere "Aaron W. Swenson" <titanofold@g.o>