Gentoo Archives: gentoo-dev

From: Jon Portnoy <avenj@g.o>
To: gentoo-dev@g.o
Subject: Re: [gentoo-dev] Portage can't find gcc
Date: Mon, 17 Mar 2003 20:40:51
Message-Id: 20030317204043.GA30421@cerberus.oppresses.us
In Reply to: [gentoo-dev] Portage can't find gcc by Burton Samograd
Try: gcc-config i686-pc-linux-gnu-3.2.2


On Mon, Mar 17, 2003 at 12:31:23PM -0800, Burton Samograd wrote:
> Hi All, > > I have a gentoo 1.4 server that I left running for a while (many > months) without a rsync or update for a while due to having some > broken libraries. I fixed the libs, managed to get an rsync to work > and then did an emerge -u world which seemed to work fine until it > updated gcc (i think, but this seems like the most obvious problem). > > I figure it's an environment problem as I was having problems with not > being able to find libstdc++, which was solved by adding the > appropriate directory to LD_LIBRARY_PATH as well. > > Now it looks like the environment is out of whack or else portage > ignore environment settings as I went through and manually inserted > the paths in /etc/env.d/gcc/ and can run gcc from the command line, > but whenever I try to emerge I get an error about not being able to > find gcc. > > Are the paths or environment specified differently for portage or is > there something else I have to manually update to get this working > again? > > -- > burton samograd kruhft@×××××××××××××.org > http://kruhftwerk.dyndns.org
-- Jon Portnoy -- gentoo-dev@g.o mailing list