Gentoo Archives: gentoo-dev

From: Joshua Saddler <nightmorph@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] News item announcing as-needed (glep 42 stuff)
Date: Tue, 27 Jul 2010 00:27:56
Message-Id: 20100726172716.6daf94c9@angelstorm
In Reply to: Re: [gentoo-dev] News item announcing as-needed (glep 42 stuff) by "Paweł Hajdan
On Mon, 26 Jul 2010 13:44:36 -0700
"Paweł Hajdan, Jr." <phajdan.jr@g.o> wrote:
> This might be a bit unclear to less savvy users. How about just make > sure your LDFLAGS in /etc/make.conf contains "-Wl,--as-needed" or is unset?
> Instead of saying "overriding", I'd say something more similar to > "disabling --as-needed" and add that it is not recommended.
It should be unset; as you say, users should not be screwing with system-wide LDFLAGs, as we don't support anything but the defaults. I put an LDFLAGs FAQ in the optimization guide a long time ago: section> <title>What about LDFLAGS?</title> <body> <p> The Gentoo developers have already set basic, safe LDFLAGS in the base profiles, so you don't need to change them. </p> </body> </section

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
[gentoo-dev] Re: News item announcing as-needed (glep 42 stuff) Duncan <1i5t5.duncan@×××.net>