Gentoo Archives: gentoo-dev

From: "Michał Górny" <mgorny@g.o>
To: gentoo-dev@l.g.o
Cc: kumba@g.o, base-system@g.o
Subject: Re: [gentoo-dev] [PATCH eutils] Introduce has_iuse() for IUSE checks.
Date: Tue, 13 Sep 2011 10:45:32
Message-Id: 20110913124654.45c044d4@pomiocik.lan
In Reply to: Re: [gentoo-dev] [PATCH eutils] Introduce has_iuse() for IUSE checks. by Joshua Kinard
On Tue, 13 Sep 2011 06:39:13 -0400
Joshua Kinard <kumba@g.o> wrote:

> On 09/13/2011 06:29, Michał Górny wrote: > > > On Tue, 13 Sep 2011 12:21:31 +0200 > > Michał Górny <mgorny@g.o> wrote: > > > >> +# @FUNCTION: has_iuse > > > > Ideas for a better name will be appreciated. > > > 'in_iuse' or 'iuse_contains'? > > if $(in_iuse foobar); do > $(cake) > fi > > or > > if $(iuse_contains foobar); do > $(cake) > fi
Guess just a typo but for the record: if in_iuse foobar; then ... fi i.e. withou $(). -- Best regards, Michał Górny

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies