Gentoo Archives: gentoo-dev

From: "Tomáš Chvátal" <scarabeus@g.o>
To: gentoo-dev@l.g.o
Cc: media-video@g.o
Subject: [gentoo-dev] virtual/ffmpeg and media-video/libav
Date: Wed, 23 Mar 2011 14:10:10
Message-Id: 4D89FEC1.1030905@gentoo.org
Hi guys,
As there is new ffmpeg fork that is a bit alive we should provide it as
alternative to current media-video/ffmpeg.

So libav is stored in media-video/libav (look at it, try to find issues
and stuff).

Virtual package is virtual/ffmpeg where now i implemented it to have
versioned dependencies.
So there is virtual/ffmpeg-0.6 virtual/ffmpeg-9999 where the apps can
decide what they need.
Samuli pointed out that we do not slot ffmpeg nor support versioned deps
and always demand everything to be working with latest. If you have
strong opinion on that one please express it here so the virtual gets
redesigned to just simple virtual/ffmpeg-0.1 without any version stated
in it. I myself like the chance to express the version explicitly.
Virtual itself provide access to all useflags currently used in eapi2
deps. More can be added when required.

For what is libav i would suggest you go to their homepage
http://libav.org/ or poke Diego or Luca whom are actually members of
upstream :)

And finally the list of current dependencies over ffmpeg see in attachment.

Cheers

Tomas

Attachments

File name MIME type
libav_virtual.txt text/plain
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-dev] virtual/ffmpeg and media-video/libav Jeremy Olexa <darkside@g.o>
Re: [gentoo-dev] virtual/ffmpeg and media-video/libav "Tomáš Chvátal" <scarabeus@g.o>
[gentoo-dev] Re: virtual/ffmpeg and media-video/libav Samuli Suominen <ssuominen@g.o>
Re: [gentoo-dev] virtual/ffmpeg and media-video/libav Alexis Ballier <aballier@g.o>