Gentoo Archives: gentoo-dev

From: Enrico Weigelt <weigelt@×××××.de>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Re: libpng-1.5 smooth upgrade
Date: Sat, 26 Feb 2011 16:27:03
Message-Id: 20110226160843.GI22774@nibiru.local
In Reply to: Re: [gentoo-dev] Re: libpng-1.5 smooth upgrade by Enrico Weigelt
* Enrico Weigelt <weigelt@×××××.de> schrieb:

> > pretty please force every consumer to hardcode the version > > because i know people that want to do this" ? > > No, they should use pkg-config at buildtime and do the version > selection there (eg. the eselect-way).
Oh, it gets a bit tricker: the dependencies of the installed packages will have to be fixed to the actually used version/slot. hmm, maybe this also could be done via some eclass, that adds an useflag for libpng version selection ? I could imagine a way like that: * libpng15 is installed in a way that it doesnt conflict with existing libpng14 (different locations, pkg-config name, slotted, etc) * pass pkg-config calls through a wrapper that automatically chooses the right .pc file on some environment variable etc. * each libpng-using package that should be buildable against libpng15 is changed to use the new eclass (that does all the switching magic) IMHO this should allow keeping the (runtime) dependencies intact (no revdep-rebuild required) and allow an smooth upgrade. When everything had been rebuilt against libpng15 one day, --depclean would kick off old libpng14. cu -- ---------------------------------------------------------------------- Enrico Weigelt, metux IT service -- http://www.metux.de/ phone: +49 36207 519931 email: weigelt@×××××.de mobile: +49 151 27565287 icq: 210169427 skype: nekrad666 ---------------------------------------------------------------------- Embedded-Linux / Portierung / Opensource-QM / Verteilte Systeme ----------------------------------------------------------------------

Replies

Subject Author
Re: [gentoo-dev] Re: libpng-1.5 smooth upgrade "Rémi Cardona" <remi@g.o>