Gentoo Archives: gentoo-dev

From: Sebastian Luther <SebastianLuther@×××.de>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-im/qutecom: metadata.xml ChangeLog qutecom-2.2_p20110210.ebuild
Date: Thu, 13 Oct 2011 18:16:49
Message-Id: 4E972ADA.8020000@gmx.de
In Reply to: Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in net-im/qutecom: metadata.xml ChangeLog qutecom-2.2_p20110210.ebuild by Ciaran McCreesh
Am 13.10.2011 15:13, schrieb Ciaran McCreesh:
> On Thu, 13 Oct 2011 12:23:07 +0200 > Chí-Thanh Christopher Nguyễn <chithanh@g.o> wrote: >> So qutecom is not broken and needs not be removed as long as >> <linux-headers-2.6.38 is in the tree. > > Dependencies using <, <=, =, ~ or =* are broken, except in certain > special situations inside ||. >
Why exactly are they broken? Sure, it will force the user to choose between installing this and having the latest version of the package installed. But I don't see this being a problem. As an example I always get this on world updates: WARNING: One or more updates have been skipped due to a dependency conflict: dev-python/numpy:0 (dev-python/numpy-1.6.0::gentoo, ebuild scheduled for merge) conflicts with ~dev-python/numpy-1.5.1 required by (sci-mathematics/sage-4.7.1-r2::sage-on-gentoo, installed) dev-python/pexpect:0 (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for merge) conflicts with ~dev-python/pexpect-2.0 required by (sci-mathematics/sage-4.7.1-r2::sage-on-gentoo, installed) Fact is that sci-mathematics/sage can't be made work without those deps. Fact is that I want this package and couldn't care less if I have the latest version of these other two packages. If in turn I cared for the other two packages, then I would have to remove sage. It's a choice but nothing else. And before some asks, no portage wouldn't break this dep these days: # emerge -1u --ignore-default-opts -vtp pexpect These are the packages that would be merged, in reverse order: Calculating dependencies... done! Total: 0 packages, Size of downloads: 0 kB WARNING: One or more updates have been skipped due to a dependency conflict: dev-python/pexpect:0 (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for merge) conflicts with ~dev-python/pexpect-2.0 required by (sci-mathematics/sage-notebook-0.8.19-r1::sage-on-gentoo, installed) Sebastian

Replies