Gentoo Archives: gentoo-dev

From: "Robin H.Johnson" <robbat2@g.o>
To: Matthew Walker <mwalker@×××××××.net>
Cc: gentoo-dev@g.o
Subject: Re: [gentoo-dev] MySQL 4 still marked unstable?
Date: Mon, 19 May 2003 07:34:31
Message-Id: 20030519073430.GB3549@cherenkov.orbis-terrarum.net
On Fri, May 16, 2003 at 10:16:36AM -0600, Matthew Walker wrote:
> As someone who has used MySQL 4 in a production environment on Gentoo since > the official release was declared stable, I'm baffled why it hasn't been > unmasked yet. It works beautifully, and is a seamless upgrade process. I'd > really like to use it on my new production server at work, but I refuse to > use any masked packages, to keep maintenance overhead to a minimum. > Anyway... Is there a reason it's still masked?
Seeing the thread on this, I'd like to speak up with an answer, since I do a lot of the maintance on MySQL and it's related ebuilds. The upgrade ISN'T as seamless as we would like. Presently if you are running MySQL-3 and you emerge MySQL-4, there is an instruction telling you to rebuild everything that links against MySQL. We have had a LARGE number of bugs submitted because people didn't read the instruction to rebuild their system and then all complained about stuff being broken. As such, we are waiting for a decent script or better reverse dependancies in portage to release it to stable. Such a script is showstopper for the 1.4 release so it will be done. The same problem exists with a number of other packages. -- Robin Hugh Johnson E-Mail : robbat2@××××××××××××××.net Home Page : http://www.orbis-terrarum.net/?l=people.robbat2 ICQ# : 30269588 or 41961639 GnuPG FP : 11AC BA4F 4778 E3F6 E4ED F38E B27B 944E 3488 4E85