Gentoo Archives: gentoo-dev

From: Mark Gordon <mark.gt@×××××××××××××××.uk>
To: gentoo-dev@g.o
Subject: Re: [gentoo-dev] Subversion ebuild
Date: Fri, 25 Apr 2003 14:01:53
Message-Id: 20030425150149.786df053.mark.gt@flash-gordon.me.uk
In Reply to: Re: [gentoo-dev] Subversion ebuild by Grant Goodyear
On 25 Apr 2003 09:27:08 -0400
Grant Goodyear <g2boojum@g.o> wrote:

> On Fri, 2003-04-25 at 08:00, Mark Gordon wrote: > > Why does it install BerkleyDB 4 rather that depending on it? > > > > I already have version 4 installed using the ebuild for it since I > > am doing some development work against it (why work do a new project > > against an earlier version?) so having it as part of subversion as > > well seems wrong. > > The problem is that db4 is still masked in portage because some > packages won't build against it. There's a goal of getting all > packages in Portage db4-ready, and we're nearly at the point where > people building a brand-new system can build a db4-only system w/o any > real problems.
I've obviously not rebuilt any of the problem packages since installing db4. If you want, I might be able to spend some time testing and maybe fixing builds of some packages.
> Then we have to come up with a good way to handle the > people who will be upgrading w/o breaking their systems. We probably > need somebody dedicated to working on just db4-related issues right > now, but we don't have the resources at the moment.
I cancel my vote for unmasking it, we can't go breaking peoples boxes. If you want anything specific looked at, then I can try to find time to look since Berkeley DB is important for a project I'm on at work. -- Mark Gordon Paid to be a Geek & a Senior Software Developer Currently looking for a new job commutable from Slough, Berks, U.K. Although my email address says spamtrap, it is real and I read it. -- gentoo-dev@g.o mailing list