Gentoo Archives: gentoo-dev

From: hasufell <hasufell@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] gtk3 useflag and support of older toolkits
Date: Sun, 24 Jun 2012 09:14:04
Message-Id: 4FE6D951.7020409@gentoo.org
In Reply to: Re: [gentoo-dev] gtk3 useflag and support of older toolkits by Ben de Groot
On 06/24/2012 10:07 AM, Ben de Groot wrote:
> I don't see what the problem is now. We have slots, usedeps and > required_use. Why would we need to avoid using gtk2/gtk3 useflags? > > We of the Qt team are expecting Qt5 to enter the tree within the > next few months, and I'm not expecting any trouble with using > qt4 and qt5 useflags.
Afais qt team has done this from the start? If there was no "gtk" useflag, but only "gtk2" the situation would maybe be different. Now we have gtk, gtk2 and gtk3 and the user has to figure out what they mean for each package, cause they are not used consistently. This is a problem. Either cleanly avoid slot reference in useflag name or go it all the way, but afaik the gnome herd is not interested much in supporting older versions of gtk+, so the first way seems the best.

Replies

Subject Author
Re: [gentoo-dev] gtk3 useflag and support of older toolkits Gilles Dartiguelongue <eva@g.o>