Gentoo Archives: gentoo-dev

From: Ciaran McCreesh <ciaran.mccreesh@××××××××××.com>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it
Date: Fri, 19 Mar 2010 09:30:52
Message-Id: 20100319093033.16437529@snowmobile
In Reply to: Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it by Dale
On Fri, 19 Mar 2010 04:23:31 -0500
Dale <rdalek1967@×××××.com> wrote:
> > It's being installed because it's a dependency of something you use. > > > > Replace Python with any other library and we wouldn't be having this > > discussion. > > OK. Right now, as you type this, what package depends on python-3 > and won't work with python-2? Anything at all? If it is nothing, > then why install it?
And that's where you're making the mistake: you're treating Python as being different from every other package. In every other case, you want things to be using the newest version of a slotted package where possible. Why aren't you complaining that you were forced to install gcc 4.3 and 4.1 when 3.4 worked just fine? -- Ciaran McCreesh

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it Dale <rdalek1967@×××××.com>