Gentoo Archives: gentoo-dev

From: Joshua Kinard <kumba@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Re: Let's redesign the entire filesystem!
Date: Thu, 15 Mar 2012 11:05:56
Message-Id: 4F61CCD4.9000002@gentoo.org
In Reply to: Re: [gentoo-dev] Re: Let's redesign the entire filesystem! by Greg KH
On 03/14/2012 11:04, Greg KH wrote:

> > Not always, no, it isn't obvious that something didn't start up > correctly, or that it didn't fully load properly. Some programs later > on recover and handle things better.
I'm well aware of what I run on my own box, and when something isn't running, I figure it out pretty quickly. I tested udev-181 in a Gentoo VM that I put together recently, giving it a separate /usr, and made sure that CONFIG_DEVTMPFS was enbaled. The only service that failed to load properly at startup was udev, specifically because udevadm couldn't locate libkmod (likely because kmod installs into /usr/lib*, which wasn't available yet because I also don't use an initramfs in my kernel). Everything else worked fine, and udev later started properly once localmount was complete. I even tried, out of curiosity, to tweak things and moved udev from sysinit to boot and then to default runlevel. In 'boot', udevadm still fails to load, so no change. In 'default', only net.lo failed because the 'lo' device didn't yet exist until after udev was running. udev itself loaded fine, and the networking scripts restarted themselves. So with the one exception of networking, which in Linux, has never created /dev nodes (has to be some historical piece on why), one almost doesn't need udev at boot to even get things working on a very simple setup like mine. And since udev is the one service that didn't load correctly, one COULD put forth the hypothesis that it is udev that is "broken". But I doubt that will get much traction, right? This does lead me to wonder if a light-weight udev could exist that lacks half or more of the functionality of the current udev. I'll be honest, I've only edited my udev rules file once, and that was only when I installed a Sun Happy Meal quad ethernet card in which all four ports utilize the same MAC address and udev doesn't handle this very gracefully (if I had Solaris, I could edit the card's firmware and change this setting). Devtmpfs quite literally handles 98% of my particular usage scenario. Does that apply to everyone? Nope. Just an interesting observation. -- Joshua Kinard Gentoo/MIPS kumba@g.o 4096R/D25D95E3 2011-03-28 "The past tempts us, the present confuses us, the future frightens us. And our lives slip away, moment by moment, lost in that vast, terrible in-between." --Emperor Turhan, Centauri Republic

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies