Gentoo Archives: gentoo-dev

From: Thomas Sachau <tommy@g.o>
To: gentoo-dev@l.g.o
Subject: Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it
Date: Thu, 18 Mar 2010 19:48:01
Message-Id: 4BA28357.2030206@gentoo.org
In Reply to: Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it by Arfrever Frehtes Taifersar Arahesis
On 03/18/2010 08:33 PM, Arfrever Frehtes Taifersar Arahesis wrote:
> 2010-03-18 20:20:02 Thomas Sachau napisaƂ(a): >> Currently, some packages just depend on "dev-lang/python". Arfrever claims it to be right > > It's correct only for packages (e.g. dev-python/setuptools), which support all > versions of Python (including Python 3).
Can you tell us any benefit for the normal user, when you require him to install python-3* and to install the python related packages additionally for python-3*, while the system python is still 2.6* and wont change in the near future?
> >> Arfrever claims current portage behaviour is wrong > > I claim that Portage behavior is correct. >
So you want everyone to install python-3*? See above question. -- Thomas Sachau Gentoo Linux Developer

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-dev] Packages pulling in python-3*, also they dont require it Arfrever Frehtes Taifersar Arahesis <Arfrever@g.o>