Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-dev
Navigation:
Lists: gentoo-dev: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: Gentoo Development <gentoo-dev@g.o>
From: Arfrever Frehtes Taifersar Arahesis <Arfrever@g.o>
Subject: Re: Packages pulling in python-3*, also they dont require it
Date: Fri, 19 Mar 2010 10:35:47 +0100
2010-03-19 10:23:31 Dale napisał(a):
> Ciaran McCreesh wrote:
> > On Fri, 19 Mar 2010 03:54:28 -0500
> > Dale<rdalek1967@...>  wrote:
> >    
> >> Ciaran McCreesh wrote:
> >>      
> >>> On Thu, 18 Mar 2010 23:17:17 +0100
> >>> Ben de Groot<yngwin@g.o>   wrote:
> >>>
> >>>        
> >>>> Because it is extremely useless to the great majority of users.
> >>>>
> >>>>          
> >>> Most packages in the tree are useless to the great majority of
> >>> users.
> >>>        
> >> Which is why most users don't install everything.  I have about 1000
> >> packages installed here.  The packages installed are either something
> >> I use or a dependency of something I use.  What exactly is this being
> >> installed for again?  If nothing depends on it, there is no need to
> >> have it.
> >>      
> > It's being installed because it's a dependency of something you use.
> >
> > Replace Python with any other library and we wouldn't be having this
> > discussion.
> >
> >    
> 
> OK.  Right now, as you type this, what package depends on python-3 and 
> won't work with python-2?  Anything at all?  If it is nothing, then why 
> install it?
> 
> Since python-3 is not what the system is using, it's not getting used 
> even if it is installed.  So as I mentioned in another reply, portage is 
> installing something and it is just sitting there doing nothing.  What 
> is the point in that?

I can add "python2" USE flag (enabled by default) to some versions of
dev-lang/python. With USE="-python2", Python 2 will not be required and
Python 3 will be set as main active version of Python.

-- 
Arfrever Frehtes Taifersar Arahesis
Attachment:
signature.asc (This is a digitally signed message part.)
Replies:
Re: Packages pulling in python-3*, also they dont require it
-- Petteri Räty
References:
Packages pulling in python-3*, also they dont require it
-- Thomas Sachau
Re: Packages pulling in python-3*, also they dont require it
-- Ciaran McCreesh
Re: Packages pulling in python-3*, also they dont require it
-- Dale
Navigation:
Lists: gentoo-dev: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Packages pulling in python-3*, also they dont require it
Next by thread:
Re: Packages pulling in python-3*, also they dont require it
Previous by date:
Re: Packages pulling in python-3*, also they dont require it
Next by date:
Re: Packages pulling in python-3*, also they dont require it


Updated Jun 29, 2012

Summary: Archive of the gentoo-dev mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.