Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-dev
Navigation:
Lists: gentoo-dev: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-dev@g.o
From: Mike Frysinger <vapier@g.o>
Subject: Re: x32 release candidate
Date: Tue, 5 Jun 2012 22:17:32 -0400
compiler wise, you do not need to specify -mx32 yourself.  the toolchain 
defaults to the x32 ABI (and all programs in there are compiled as x32).  you 
only need -mx32 if you want to do something like distcc and execute with 
toolchains that aren't targeting x32 by default.

as for what are valid flags, pretty much everything that works with your amd64 
target will work with x32.  very little is different between them.
-mike
Attachment:
signature.asc (This is a digitally signed message part.)
References:
x32 fun pants
-- Mike Frysinger
x32 release candidate
-- Mike Frysinger
Navigation:
Lists: gentoo-dev: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
x32 release candidate
Next by thread:
Re: x32 release candidate
Previous by date:
Re: [gentoo-portage-dev] About forcing rebuilds of other packages issue
Next by date:
Re: [gentoo-portage-dev] About forcing rebuilds of other packages issue


Updated Jun 29, 2012

Summary: Archive of the gentoo-dev mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.