On Sun, Jun 10, 2012 at 01:25:55PM +0100, Ciaran McCreesh wrote:
> On Sat, 09 Jun 2012 13:55:53 -0700
> Zac Medico <email@example.com> wrote:
> > A dependency atom will have optional SLOT and ABI_SLOT parts. Using
> > the dbus-glib depedency on glib:2 as an example , the dbus-glib
> > dependency will be expressed with an atom such as dev-libs/glib:2:=
> > and the package manager will translate that atom to
> > dev-libs/glib:2:=2.32 at build time. So, ':' is always used to
> > distinguish SLOT deps, and ':=' is always used to distinguish
> > ABI_SLOT deps. Is that syntax good?
> Here's a nicer syntax: no ABI_SLOT variable, and SLOT="2/2.32".
Hate the slash; just looks ugly to me (so starts the bikeshed).
Sans that naggle, notions fine however; not sure I'm a fan of people
being able to specify the exact ABI they need from an ebuild while
it's in source form, but may be of use for emul-* packages.