Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-dev
Navigation:
Lists: gentoo-dev: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-dev@g.o
From: Thomas Sachau <tommy@g.o>
Subject: Re: Packages pulling in python-3*, also they dont require it
Date: Thu, 18 Mar 2010 21:13:01 +0100
On 03/18/2010 08:55 PM, Arfrever Frehtes Taifersar Arahesis wrote:
> 2010-03-18 20:47:35 Thomas Sachau napisał(a):
>> On 03/18/2010 08:33 PM, Arfrever Frehtes Taifersar Arahesis wrote:
>>> 2010-03-18 20:20:02 Thomas Sachau napisał(a):
>>>> Currently, some packages just depend on "dev-lang/python". Arfrever claims it to be right
>>>
>>> It's correct only for packages (e.g. dev-python/setuptools), which support all
>>> versions of Python (including Python 3).
>>
>> Can you tell us any benefit for the normal user, when you require him to install python-3*
> 
> I don't require it. It's only a side effect of correct dependencies.
> 

Wrong. Correct dependencies only require the set of packages they need, they dont pull in packages
nor versions, which are not used or needed.
Since you claim portage behaviour being right and you dont want to change "dev-lang/python"
dependency, you want to force all users to install python-3*, also it is not needed nor used nor is
there any benefit from it being installed.

-- 
Thomas Sachau

Gentoo Linux Developer

Attachment:
signature.asc (OpenPGP digital signature)
References:
Packages pulling in python-3*, also they dont require it
-- Thomas Sachau
Re: Packages pulling in python-3*, also they dont require it
-- Arfrever Frehtes Taifersar Arahesis
Re: Packages pulling in python-3*, also they dont require it
-- Thomas Sachau
Re: Packages pulling in python-3*, also they dont require it
-- Arfrever Frehtes Taifersar Arahesis
Navigation:
Lists: gentoo-dev: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: Packages pulling in python-3*, also they dont require it
Next by thread:
Re: Packages pulling in python-3*, also they dont require it
Previous by date:
Re: Packages pulling in python-3*, also they dont require it
Next by date:
Re: Packages pulling in python-3*, also they dont require it


Updated Jun 29, 2012

Summary: Archive of the gentoo-dev mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.