Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-dev
Navigation:
Lists: gentoo-dev: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-dev@g.o
From: James Cloos <cloos@...>
Subject: Re: GCC upgrades, FUD and gentoo documentation
Date: Sat, 08 Oct 2011 18:57:23 -0400
>>>>> "SV" == Sven Vermeulen <swift@g.o> writes:

SV> - Since 3.4.0/4.1.0, the C++ ABI is forward-compatible, so rebuilds
SV>   from that version onwards should not be needed

That is not generally true.

I use gcc-4.5 as my system gcc, but mostly use 4.6 when building things
outside of portage.  I still run into compilation errors with C++ which
go away if I compile said code with 4.5.

GCC’s C++ abi is only *mostly* forwards compatible, not *entirely*.

-JimC
-- 
James Cloos <cloos@...>         OpenPGP: 1024D/ED7DAEA6


Replies:
Re: GCC upgrades, FUD and gentoo documentation
-- Mike Frysinger
Re: GCC upgrades, FUD and gentoo documentation
-- Matt Turner
References:
GCC upgrades, FUD and gentoo documentation
-- Sven Vermeulen
Navigation:
Lists: gentoo-dev: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
GCC upgrades, FUD and gentoo documentation
Next by thread:
Re: GCC upgrades, FUD and gentoo documentation
Previous by date:
Re: integrity of stage files
Next by date:
Re: integrity of stage files


Updated Jun 29, 2012

Summary: Archive of the gentoo-dev mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.