Gentoo Archives: gentoo-embedded

From: "Raúl Porcel" <armin76@g.o>
To: "pandaswarm@×××××.com" <pandaswarm@×××××.com>
Cc: gentoo-embedded@l.g.o, "Hanno Böck" <hanno@g.o>
Subject: Re: [gentoo-embedded] About howto install Gentoo on Toshiba AC100
Date: Fri, 17 Jun 2011 20:06:18
Message-Id: 4DFBACDE.6080604@gentoo.org
In Reply to: [gentoo-embedded] About howto install Gentoo on Toshiba AC100 by "pandaswarm@gmail.com"
Hi,

I'm sorry but i have no idea. My guide is for the tegra250 developer
kit, i don't have an AC100 so i can't do anything for it since i don't
know if it'll work, besides its setup is more complicated than the devkit.

Regarding your questions.

1. The devkit only has 512M of NAND. The devkit has an atheros AR6002
wifi, while the AC100 has a Ralink.
2. I don't know
3. See above

I'm cc'ing Hanno since he has an AC100 with gentoo running on it iirc.
Also i'd suggest you join the IRC channel #ac100 at irc.freenode.net and
ask there, there are some people running Gentoo.

I'm sorry i can't help more.

On 06/17/2011 11:42 AM, pandaswarm@×××××.com wrote:
> Hi, Raúl > > As a newbie to AC100 and Gentoo-Embedded, > I just trying to following with installation guide: > http://tosh-ac100.wetpaint.com/page/Gentoo > http://dev.gentoo.org/~armin76/arm/tegra2/install.xml > > but seems kernel config file is for Tegra 250 Developer kit? > and I also suffered some errors when trying to duplicate step like build kernel > > [snip] > LD drivers/built-in.o > LD vmlinux.o > sound/built-in.o: In function `NvOdmExternalClockConfig': > /home/hzhang/ac100/kernel/sound/soc/tegra/tegra_soc_audio.c:48: > multiple definition of `NvOdmExternalClockConfig' > arch/arm/mach-tegra/built-in.o:/home/hzhang/ac100/kernel/arch/arm/mach-tegra/nvodm/nvodm_services.c:254: > first defined here > sound/built-in.o: In function `NvRmTransportSendMsg': > /home/hzhang/ac100/kernel/sound/soc/tegra/tegra_transport.c:45: > multiple definition of `NvRmTransportSendMsg' > arch/arm/mach-tegra/built-in.o:/home/hzhang/ac100/kernel/arch/arm/mach-tegra/nvrm/core/common/nvrm_transport.c:1561: > first defined here > sound/built-in.o: In function `NvRmTransportGetPortName': > /home/hzhang/ac100/kernel/sound/soc/tegra/tegra_transport.c:77: > multiple definition of `NvRmTransportGetPortName' > arch/arm/mach-tegra/built-in.o:/home/hzhang/ac100/kernel/arch/arm/mach-tegra/nvrm/core/common/nvrm_transport.c:1681: > first defined here > sound/built-in.o: In function `NvRmTransportRecvMsg': > /home/hzhang/ac100/kernel/sound/soc/tegra/tegra_transport.c:60: > multiple definition of `NvRmTransportRecvMsg' > arch/arm/mach-tegra/built-in.o:/home/hzhang/ac100/kernel/arch/arm/mach-tegra/nvrm/core/common/nvrm_transport.c:1607: > first defined here > sound/built-in.o: In function `.LANCHOR0': > last.c:(.data+0x7a8): multiple definition of `s_hRmGlobal' > arch/arm/mach-tegra/built-in.o:/home/hzhang/ac100/kernel/arch/arm/mach-tegra/clock.c:162: > first defined here > sound/built-in.o: In function `NvRmTransportOpen': > /home/hzhang/ac100/kernel/sound/soc/tegra/tegra_transport.c:91: > multiple definition of `NvRmTransportOpen' > arch/arm/mach-tegra/built-in.o:/home/hzhang/ac100/kernel/arch/arm/mach-tegra/nvrm/core/common/nvrm_transport.c:867: > first defined here > sound/built-in.o: In function `NvRmTransportConnect': > /home/hzhang/ac100/kernel/sound/soc/tegra/tegra_transport.c:103: > multiple definition of `NvRmTransportConnect' > arch/arm/mach-tegra/built-in.o:/home/hzhang/ac100/kernel/arch/arm/mach-tegra/nvrm/core/common/nvrm_transport.c:1283: > first defined here > sound/built-in.o: In function `NvRmTransportClose': > /home/hzhang/ac100/kernel/sound/soc/tegra/tegra_transport.c:113: > multiple definition of `NvRmTransportClose' > arch/arm/mach-tegra/built-in.o:/home/hzhang/ac100/kernel/arch/arm/mach-tegra/nvrm/core/common/nvrm_transport.c:993: > first defined here > make: *** [vmlinux.o] Error 1 > > so I have couple of quick questions: > 1. AC100 shared almost the same hardware spec with Nvidia Tegra 250 > Developer Kit? > 2. Re-partition AC100 internal storage still a hard requirement before > install Gentoo? > 3. Could you please provide an updated binary Gentoo kernel+initrd > image for AC100? > > Thanks in advance. >