Gentoo Archives: gentoo-embedded

From: "Scott L. Price" <prices@××××××××.com>
To: gentoo-embedded@l.g.o
Subject: Re: [gentoo-embedded] dropbear and telnetd problem
Date: Sun, 05 Mar 2006 02:36:52
Message-Id: 440A4F15.7030905@dflytech.com
In Reply to: Re: [gentoo-embedded] dropbear and telnetd problem by Kumba
I had that same problem when /dev/ptmx (I think) was missing.  It seems 
to be some sort of multiplexer for ptys.  I am not sure of it's exact 
function.

Scott  =)

Kumba wrote:
> Jakub Ladman wrote: > >> / $ dropbear -F -E >> [16] Jan 01 00:02:03 Not forking >> [17] Jan 01 00:02:26 Child connection from 10.16.1.130:45326 >> [17] Jan 01 00:02:28 Warning: Reading the random source seems to have >> blocked. >> If you experience problems, you probably need to find a better entropy >> source. >> [17] Jan 01 00:02:45 password auth succeeded for 'root' from >> 10.16.1.130:45326 >> [17] Jan 01 00:02:45 pty_allocate: openpty: No such device >> [17] Jan 01 00:02:45 no pty was allocated, couldn't execute >> But i don't know what to do. :-( > > > Sounds like the /dev/pts issue solar mentioned a few mails back. Make > sure /dev/pts exists, and you have it mounted as devpts (mount devpts > /dev/pts -t devpts), and see if that fixes it. > > > --Kumba > > -- > Gentoo/MIPS Team Lead > Gentoo Foundation Board of Trustees > > "Such is oft the course of deeds that move the wheels of the world: > small hands do them because they must, while the eyes of the great are > elsewhere." --Elrond
-- Electrical Engineering/Web Development Dragonfly Technologies, Inc. http://www.dflytech.com Hunt Utilities Group LLC http://www.hugllc.com Hopkins, MN (952) 935-2418 -- gentoo-embedded@g.o mailing list