Gentoo Archives: gentoo-embedded

From: Petr Podrabsky <petrpo@×××××.com>
To: gentoo-embedded@l.g.o
Subject: [gentoo-embedded] GNAP extensions
Date: Mon, 23 Oct 2006 07:01:06
Message-Id: 5852c7e30610230000x5f087054jd62b2f4bfb27482a@mail.gmail.com
Hello guys,

I have some questions about GNAP. I have GNAP, catalyst 2.0 versions,
squashfs-tools 3.0, gcc 4.1.1. A default portage snapshot from gnap
package is very small (1,7MB). I can see there are missing some
packages that I need (hostap-driver, and so on…). Ok. In this case I
have to define extensions in myspecs01 dir:

--extensions-conf:
# List of extensions to build
extensions: less hostap-driver hostap-utils quagga

# hostap-driver extension
hostap-driver/packlist: hostap-driver
#hostap-driver/cleanup: /usr/share

# hostp-utils extension
hostap-utils/packlist: hostap-utils
#hostap-utils/cleanup: /usr/share

# less extension
less/packlist: less
less/cleanup: /usr/share

# quagga extension
quagga/packlist: quagga
quagga/cleanup: /usr/share /etc/quagga/samples /usr/include /usr/lib/perl5
--end of file extensions.conf

Then I tried to do extensions like this:
#gnap_make -t extensions -e less -e hostap-driver -e hostap-utils -e
quagga -p portage-20061006.tar.bz2 -o router05 -e myspecs01 -v
20061006C

Gnap_make ends with error:
.....
app-misc/pax-utils
    selected: 0.1.10
   protected: 0.1.13
     omitted: none

>>> 'Selected' packages are slated for removal. >>> 'Protected' and 'omitted' packages will not be removed.
>>> Waiting 5 seconds before starting... >>> (Control-C to abort)... >>> Unmerging in: 5 4 3 2 1 >>> Unmerging app-misc/pax-utils-0.1.10...
No package files given... Grabbing a set. --- !mtime obj /usr/bin/scanelf --- !mtime obj /usr/bin/pspax --- !mtime obj /usr/bin/dumpelf --- !empty dir /usr/bin --- !empty dir /usr
>>> emerge (9 of 20) sys-apps/portage-2.1.1 to /
!!! Security Violation: A file exists that is not in the manifest. !!! File: files/digest-portage-2.1.2_pre2-r2 Traceback (most recent call last): File "modules/grp_target.py", line 58, in run_local +" "+pkgset+" "+mypackages,env=self.env) File "/usr/lib/catalyst/modules/catalyst_support.py", line 487, in cmd raise CatalystError,myexc CatalystError: <unprintable instance object> None !!! catalyst: GRP build aborting due to error. Catalyst aborting.... lockfile does not exist '/var/tmp/catalyst/tmp/gnap/grp-x86-20061006C/.catalyst_lock' How I can solve this portage problem? Is there any problem I use for GNAP nearly latest portage snapshot (portage-20061006.tar.bz2 = ~37MB) ? Should I use some "better" and smaller portage for GNAP? Where should I find „better" portage snapshot (not big like 37MB) where hostap-driver, hostap-utils,quagga are included? Can I do gnap_make –t all with latest portage like this: gnap_make –t all –p portage-20061017.tar.bz2 Thanks for any info. Petr -- gentoo-embedded@g.o mailing list

Replies

Subject Author
Re: [gentoo-embedded] GNAP extensions Sune Kloppenborg Jeppesen <jaervosz@g.o>
Re: [gentoo-embedded] GNAP extensions Janusz Syrytczyk <jsyrytczyk@×××××××××.pl>