Gentoo Archives: gentoo-embedded

From: "Morgan
To: "'gentoo-embedded@l.g.o'" <gentoo-embedded@l.g.o>
Subject: RE: [gentoo-embedded] GNAP and DOM
Date: Thu, 14 Jul 2005 21:21:16
Message-Id: 9D5278FD9797104EADCFCFA97AE37A9E01643D@kc-atss-exs02.mail.saic.com
Have you tried using the flash_write utility from mdt?  I think that might
be the way to go.

Austin

-----Original Message-----
From: gentoo-embedded+bounces-275-AUSTIN.D.MORGAN=saic.com@g.o
[mailto:gentoo-embedded+bounces-275-AUSTIN.D.MORGAN=saic.com@g.o] On
Behalf Of Robin Bonin
Sent: Thursday, July 14, 2005 4:11 PM
To: gentoo-embedded@l.g.o
Subject: Re: [gentoo-embedded] GNAP and DOM


I tried installing gnap on a hard drive, and it works. when I run the exact
same command to install it on the DOM I get the blank screen w/ flashing
cursor. Any thoughts other than using partition magick or something the copy
the data from the workign hard drve to the DOM? I have several variations I
need to create that will take some time.

On 7/14/05, Robin Bonin <rbonin@×××××.com> wrote:
> After running dd and trying it a few times, it seems that it has > worked? I now am getting past that not boot record error and not I'm > sitting at a black screen completley blank with the cursor at the top > left. > > I created both a standard linux partition and ran gnap overlay and > also a fat32 and ran gnap overlay (Documentation didn't say what type > of partition) I'm didn't get any diffrence in the output, so I'm not > sure what is happening. > > I have a working iso, is there anyway I can place those files on the > DOM? and get it to boot up that way? > > On 7/14/05, Morgan, Austin <AUSTIN.D.MORGAN@××××.com> wrote: > > I have noticed that DOM's do not like dd very much. I have a > > feeling that it has something to do with how it works with back > > blocks. I have found the only reliable way to put files on a DOM is > > to tar/gzip them up and explode them on it. I do not know how you > > would go about this with the MBR due to it's special circumstances. > > > > Austin > > > > -----Original Message----- > > From: > > gentoo-embedded+bounces-269-AUSTIN.D.MORGAN=saic.com@g.o > > To: gentoo-embedded@l.g.o > > Sent: 7/14/2005 10:11 AM > > Subject: [gentoo-embedded] GNAP and DOM > > > > Hi, I'm using gnap tools 1.2 and I am trying to put my working > > overlay onto a 32 meg DOM. Following the instructions here, > > http://www.gentoo.org/proj/en/base/embedded/gnap-userguide.xml > > I have installed the MBR, created the primary active partition > > and then ran gnap overlay. > > > > > > when I boot, I get Searching for Boor Record from IDE-0..Not Found > > > > when I run > > dd if=/home/robin/gnap/gnap-tools-1.2/mbr/mbr.bin of=/dev/hdc bs=512 > > count=1 I get > > 0+1 records in > > 0+1 records out > > > > any other things I need to check? > > > > -- > > gentoo-embedded@g.o mailing list > > -- > > gentoo-embedded@g.o mailing list > > > > >
-- gentoo-embedded@g.o mailing list -- gentoo-embedded@g.o mailing list

Replies

Subject Author
RE: [gentoo-embedded] GNAP and DOM Ned Ludd <solar@g.o>