Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-embedded
Navigation:
Lists: gentoo-embedded: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: Mike Frysinger <vapier@g.o>
From: Ed W <lists@...>
Subject: Re: tar-1.26 not unpacking archives with symlinks?
Date: Tue, 03 Apr 2012 14:35:47 +0100
On 02/04/2012 05:38, Mike Frysinger wrote:
> On Wednesday 29 February 2012 12:33:02 Ed W wrote:
>> Hi, I'm hitting an error when trying to unpack archives with the
>> recently unmasked tar-1.26.  Basically any symlinks in the archive
>> trigger an "unknown file" error.  This prevents me using emerge -k
>> amongst other things
>>
>> I only see this on uclibc-0.9.33 based system, not on the build host
>> which uses glibc amd64
>>
>> Can anyone else repro this and shed any light on what the problem might
>> be?  Problem in tar or uclibc?
> fchmodat() is a syscall that takes 3 args.  uClibc was providing a stub that
> treated it as 4.  i fixed things up, so if you want to try with the fix i just
> committed, that'd be nice ...
> -mike

Excellent - many thanks

Out of the country at present - will verify on my return

Again many thanks

Ed W


References:
tar-1.26 not unpacking archives with symlinks?
-- Ed W
Re: tar-1.26 not unpacking archives with symlinks?
-- Mike Frysinger
Navigation:
Lists: gentoo-embedded: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: tar-1.26 not unpacking archives with symlinks?
Next by thread:
ARM manuals
Previous by date:
Re: tar-1.26 not unpacking archives with symlinks?
Next by date:
test


Updated Jun 25, 2012

Summary: Archive of the gentoo-embedded mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.