Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-embedded
Navigation:
Lists: gentoo-embedded: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-embedded@g.o
From: Robin Bonin <rbonin@...>
Subject: Re: GNAP and DOM
Date: Thu, 14 Jul 2005 16:10:52 -0500
I tried installing gnap on a hard drive, and it works. when I run the
exact same command to install it on the DOM I get the blank screen w/
flashing cursor. Any thoughts other than using partition magick or
something the copy the data from the workign hard drve to the DOM? I
have several variations I need to create that will take some time.

On 7/14/05, Robin Bonin <rbonin@...> wrote:
> After running dd and trying it a few times, it seems that it has worked?
> I now am getting past that not boot record error and not I'm sitting
> at a black screen completley blank with the cursor at the top left.
> 
> I created both a standard linux partition and ran gnap overlay and
> also a fat32 and ran gnap overlay (Documentation didn't say what type
> of partition) I'm didn't get any diffrence in the output, so I'm not
> sure what is happening.
> 
> I have a working iso, is there anyway I can place those files on the
> DOM? and get it to boot up that way?
> 
> On 7/14/05, Morgan, Austin <AUSTIN.D.MORGAN@...> wrote:
> > I have noticed that DOM's do not like dd very much.  I have a feeling that
> > it has something to do with how it works with back blocks.  I have found the
> > only reliable way to put files on a DOM is to tar/gzip them up and explode
> > them on it.  I do not know how you would go about this with the MBR due to
> > it's special circumstances.
> >
> > Austin
> >
> > -----Original Message-----
> > From: gentoo-embedded+bounces-269-AUSTIN.D.MORGAN=saic.com@g.o
> > To: gentoo-embedded@g.o
> > Sent: 7/14/2005 10:11 AM
> > Subject: [gentoo-embedded] GNAP and DOM
> >
> > Hi, I'm using gnap tools 1.2 and I am trying to put my working overlay
> > onto a 32 meg DOM.
> > Following the instructions here,
> > http://www.gentoo.org/proj/en/base/embedded/gnap-userguide.xml
> > I have installed the MBR, created the primary active partition
> > and then ran gnap overlay.
> >
> >
> > when I boot, I get Searching for Boor Record from IDE-0..Not Found
> >
> > when  I run
> > dd if=/home/robin/gnap/gnap-tools-1.2/mbr/mbr.bin of=/dev/hdc bs=512
> > count=1
> > I get
> > 0+1 records in
> > 0+1 records out
> >
> > any other things I need to check?
> >
> > --
> > gentoo-embedded@g.o mailing list
> > --
> > gentoo-embedded@g.o mailing list
> >
> >
>

-- 
gentoo-embedded@g.o mailing list


Replies:
Re: GNAP and DOM
-- Thierry Carrez
References:
RE: GNAP and DOM
-- Morgan, Austin
Re: GNAP and DOM
-- Robin Bonin
Navigation:
Lists: gentoo-embedded: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Re: GNAP and DOM
Next by thread:
Re: GNAP and DOM
Previous by date:
baselayout-lite and emerging into a new root?
Next by date:
RE: GNAP and DOM


Updated Jun 17, 2009

Summary: Archive of the gentoo-embedded mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.