Gentoo Logo
Gentoo Spaceship




Note: Due to technical difficulties, the Archives are currently not up to date. GMANE provides an alternative service for most mailing lists.
c.f. bug 424647
List Archive: gentoo-installer
Navigation:
Lists: gentoo-installer: < Prev By Thread Next > < Prev By Date Next >
Headers:
To: gentoo-installer@g.o
From: "Greg Morin" <gpmorin@...>
Subject: Grub causing kernel panic? - ThinkPad T40 - new install
Date: Fri, 3 Nov 2006 10:06:31 -0500
Good day,<br>
<br>
I've installed (several times) on a ThinkPad T-40, trying both manual
kernel config and genkernel. I followed the online manual explicitly (I
think). The machine is currently loaded with the manual config. Either
way, the results are similar.<br>
<br>
Grub shows the two boot options, then begins loading the OS.<br>
<br>
The machine begins to boot, starts loading modules, then kernel panics:<br>
&nbsp;&nbsp; VFS:Cannot open root device &quot;hda3&quot; or unknown-block(0,0)<br>
&nbsp;&nbsp; Please append a correct &quot;root=&quot; boot option<br>
&nbsp;&nbsp; Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)<br>
<br>
There is a single fixed disk:<br>
&nbsp;&nbsp; Device&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Boot&nbsp;&nbsp;&nbsp;&nbsp; Size&nbsp;&nbsp;&nbsp; System&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Filesystem&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Mount point<br>
&nbsp;&nbsp; =======&nbsp;&nbsp; ====&nbsp;&nbsp;&nbsp; ===== =========&nbsp;&nbsp; =========&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =========<br>
&nbsp;&nbsp; /dev/hda1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; *&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 32M&nbsp;&nbsp;&nbsp; Linux&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ext2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; /boot<br>
&nbsp;&nbsp; /dev/hda2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 3G&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Linux swap&nbsp;&nbsp;&nbsp;&nbsp; none&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; none<br>
&nbsp;&nbsp; /dev/hda3&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ~71G&nbsp; Linux&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ext3&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; /<br>
<br>
I am able to mount and use these partitions after booting from CD.
/etc/fstab (/mnt/gentoo/etc/fstab when booted from disk) looks good.<br>
<br>
Filesystems ext2 and ext3 are compiled into the kernel.<br>
<br>
Grub details:<br>
&nbsp;&nbsp; device.map<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; (hd0)&nbsp;&nbsp; /dev/hda<br>
&nbsp;&nbsp; grub.conf<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; default&nbsp;&nbsp; 0<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; timeout&nbsp;&nbsp; 5<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; splashimage=(hd0,0)/boot/grub/spash.xpm.gz<br>
<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; title=Gentoo Linux 2.6.17-r8<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; root (hd0,0)<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; kernel /boot/kernel-2.6.17-gentoo-r8 root=/dev/hda3<br>
<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; title=Gentoo Linux 2.6.17-r8 (rescue)<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; root(hd0,0)<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; kernel /boot/kernel-2.6.17-gentoo-r8 root=/dev/hda3 init=/bin/bb<br>
<br>
&nbsp;&nbsp; I used grub-install /dev/hda with no errors. I've played around with
the &quot;root=&quot; entry, but to no avail - not sure I'm understanding this
one...<br>
<br>
The kernel image appears to be valid, with no typos in filename/grub entries.<br>
<br>
Any ideas? Seems that the kernel begins to load, but can't mount the root filesystem?<br>
<br>
Thank-you for any pointers.<br clear="all"><br clear="all"><br>-- <br><br>Gpm<br>The Morins of Plantsville
Replies:
Re: Grub causing kernel panic? - ThinkPad T40 - new install
-- Ladislav Laska
Re: Grub causing kernel panic? - ThinkPad T40 - new install
-- Andrew Gaffney
Navigation:
Lists: gentoo-installer: < Prev By Thread Next > < Prev By Date Next >
Previous by thread:
Stage4
Next by thread:
Re: Grub causing kernel panic? - ThinkPad T40 - new install
Previous by date:
Re: Stage4
Next by date:
Re: Grub causing kernel panic? - ThinkPad T40 - new install


Updated Jun 17, 2009

Summary: Archive of the gentoo-installer mailing list.

Donate to support our development efforts.

Copyright 2001-2013 Gentoo Foundation, Inc. Questions, Comments? Contact us.